Koodo Community

Community

Solved

Self-serve website still painfully slow


I've asked this question a couple of weeks ago and at the time most people did not report a slow website, but some did. I'm trying to figure out if it's just at my end, but today the self-service website is very slow again.
Is anyone experiencing the same? Most of the time I use safari on my Mac, but am finding the same thing in Firefox, so I'm guessing it's not the browser (Koodo does suggest IE or Firefox)

17 replies

Userlevel 7
Badge +4
Nope, i use chrome and have ZERO issues with the site
Userlevel 7
Badge +4
Haven't gotten any reports the site would be performing slowly. Is there a particular function you are trying to use when this happens?
I tried a few different links, they all loaded very slow, I'm wondering if the page is loading completely because it doesn't show the amount of my balance, which was there a few days ago
Userlevel 6
How long does it take to load a page on your self-serve through our website? Have you tried using the mobile self-serve application meanwhile?
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

thanks Melissa I will certainly try the app, btw..website working well today 🙂
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

Been trying to create password from phone iPad n two different internet sources , watching a swirl for ten minutes n nothing. It's slow , read other forums it's slllloooowwee
Userlevel 7
Badge +4
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

It doesn't look like you have validated your account yet Nancy. We sent you an email to do that, which the Mobile Shop should have mentioned to you. Or is that the step where you are at? You got the email, clicked the validation link? Everything is working on our end that's why I'm asking. 
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

I don't think everyois working on your end because the information doesn't load . I just the same loading circle going around
Userlevel 7
Badge +4
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

Do other website load for you? Try doing this from another internet connection and see if things load for you.
What page are you trying to load in which you just see a circle going around?
Melissa wrote:

How long does it take to load a page on your self-serve through our website? Have you tried using...

That's all it does , every device I try . I have no problem with other pages
St

i
Twenty minutes still loading
Userlevel 7
Badge +4
Nancy Duguay wrote:

Twenty minutes still loading

It looks like you have picked an invalid password format. Based on the picture there is at least one exclamation mark indicating the password you have chosen cannot be used. 
Nancy Duguay wrote:

Twenty minutes still loading

I needed a cap, did that, no loading. Downloaded the Koodo app, same frustration there. Trying to log in to verify account from the email sent n nothing matches. I have lots of accounts n do online business but this has been too frustrating . Think I'm going to just switch provider
Userlevel 7
Badge +4
Nancy Duguay wrote:

Twenty minutes still loading

Not being able to tell you what the issues is, and seeing we have hundreds of new customers getting through the activation I can't blame you for your thinking.

Reply