Koodo Community
Solved

Self Serve app issues (iOS)


Userlevel 7
Badge +4
I've been having some issues with Koodo's Self Serve app on my iPhone 5. When I'm on WiFi, it lets me log in, but I get an error when trying to view bills or monitor my usage. It seems to refuse a connection. Usually, if I switch off my WiFi, I'm able to access the information. Sometimes it fails to work over a mobile connection, but it seems to refuse to work over WiFi 90% of the time. Anyone else with a similar experience?

This topic has been closed for comments

13 replies

Userlevel 7
Badge +4
I don't know about iOS but the Android self serve app just received an update. Check for an update on iOS, It may fix your issues if you here is one.
Userlevel 7
Badge +4
Anyone with an iOS device have this issue?
Userlevel 5
I assume you're having the same issue I (and a few others) have been having? I have yet to receive any notice from Koodo acknowledging this issue but I'm hoping it gets dealt with soon. It's the same app as the Telus one (which I have for my iPad) and I've NEVER had an issue with that letting me know any information... These are the other two topics I've seen. http://community.koodomobile.com/koodo/topics/fix_the_koodo_usage_app http://community.koodomobile.com/koodo/topics/problem_with_koodo_app On a side note, I got an update for the Telus app the other day... unfortunately it still does not support iPhone 5's taller screen so I'm not hopeful that Koodo's gets that support soon either. Again hopefully they fix this soon.
Userlevel 7
Badge +4
Yes.Sorry for double-posting. I hadn't seen the other posts.
Userlevel 5
Yes.Sorry for double-posting. I hadn't seen the other posts.That's fine, not worried about double posting at all! (More posts will hopefully get it to Koodo's attention in this case!). Just wanted to make sure you were having the same issue though and not something different.
Userlevel 6
Hi there, you should indeed uninstall the Koodo app and download the new version. it should be working fine 🙂 Keep us updated!
Userlevel 7
Badge +4
I did. Same issue persists.
Userlevel 5
Same as well Yannick, I've downloaded it twice and as mentioned in one of the other threads duplicated the issue on my iPhone 4S as well (primarily use my 5).
Userlevel 7
Badge +4
I'm not quite sure why this is listed as answered.
Userlevel 7
Badge +4
I'm not quite sure why this is listed as answered.Did you try uninstalling the app & reinstalling it?
I'm not quite sure why this is listed as answered.She mentioned 20 hours ago that she did 😉.
Userlevel 7
Badge +4
I'm not quite sure why this is listed as answered.I did right now, though I must point out that I'm a he 😉
Userlevel 5
I have the same problem. It will not let me view my usage. Why?