Koodo Community

Community

Solved

Received message saying I'm in USA. I am not but in Niagara Falls Canada. How to stop international roaming fees?


Received message saying I'm in USA. I am not but in Niagara Falls Canada. How to stop international roaming fees?

28 replies

Userlevel 7
Badge +4
You can choose Koodo as your carrier instead of allowing your phone to automatically choose the carrier based on what signal is strongest. If you let us know what kind of phone you have we can give you instructions on how to set this.
Allan wrote:

You can choose Koodo as your carrier instead of allowing your phone to automatically choose the c...

Thanks, done. Just don't want Koodo to charge international roaming fees.
Allan wrote:

You can choose Koodo as your carrier instead of allowing your phone to automatically choose the c...

I am visiting Niagara, Canada and receiving those texts as well and worried about roaming charges. I have a Samsung Note 3 with Koodo and can't seem to choose carriers as you suggested? Any help would be greatly appreciated.
Userlevel 7
Badge +4
Allan wrote:

You can choose Koodo as your carrier instead of allowing your phone to automatically choose the c...

Whats happening? Can you not choose one, cant find where to choose one?
Userlevel 7
Badge +4
It's Settings > Carrier > Turn Off automatic and choose from the list.
Userlevel 7
Badge +4
Another way is to simply disable roaming in your phone's settings (both for voice and for data).
Userlevel 7
Badge +4
Ivan wrote:

Another way is to simply disable roaming in your phone's settings (both for voice and for data).

Except there is no setting to disable voice roaming on an iPhone. There is the option for data, but not voice. Robert's suggestion is most straight-forward option.

Userlevel 4
Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll fix that for you :) 
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

I'm experiencing the same thing as well in Niagara Falls Canada . I went on to carrier and turned it off and selected Koodo. Hopefully no extra charges will be applied! 🙂
Userlevel 7
Badge +4
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

You can view your usage for this month and see if any extra charges have been applied. As well, remember that if you go travelling and want to use your phone outside of Koodo's network youll have to change this back.
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

Hi Daniel, just checked my present usage and there is a surprise data charge on March 12 for $5. That's the evening we arrived in Niagara Falls Canada and were at the hotel.
Userlevel 7
Badge +4
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

Data charge or texting charge? In either case you'll need to contact Koodo more directly for an adjustment of your bill. See the 'Contact Us' section at the bottom of the page.
Userlevel 4
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

Coming from a fully prepaid plan I have never had to worry about any roaming or voice accidental fees.

I think it becomes inconvenient to treat your phone like something that can cause, without any reason, some extra charges. You can easily lose peace of mind over something that should give you a pleasure, instead.

All this changes in the set up of your  phone can cause some headache for less tech savvy folks.

It is a well known problem for visitors and users that live in this area. Koodo have to find better solution for that problem.
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

I have roaming turned off, Now the phone just doesn't work PERIOD when I am at home in Fort Erie Canada. Koodo is si quick downgrade my credit when my phone was stolen and I had to pay off the tab plan IMMEDIATELY. I was only able to pay it off over a couple months (still tripled payments) yet they stayed I was behind therefore lowering my credit score. Koodo still hasn't removed ALL THE ROAMING CHARGES I was charged with here in Canada.
Userlevel 7
Badge +4
Daniel wrote:

Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll f...

@William:
Can you tell us in detail? i saw several issues there: roaming charges, stolen phone, and unpaid bill?
Thank you, I will keep an eye out for the next bill.
I have searched through all my phone settings to find a place to disable roaming or manually select the carrier, but I got a welcome to USA text this afternoon so I am guessing I will get a roaming charges. I am staying in Niagara and have not been to the USA. I have a Samsung J3. Can anyone tell me how to fix this. My alternative is to turn my phone off till I go home. Thanks. Kathleen
Userlevel 4
Hi Kathleen,

This is a pretty old topic. I would say as old as Koodo itself. Don't worry about roaming charges. Call Koodo and if you explain properly your problem they are going to wave your roaming charge. Living in Niagara, on post paid plan, can bring sometimes a lot of head ache. Probably the best option is either set properly your phone or switch to fully post paid provider like Public Mobile.
What phone are u using? IF u use an iPhone go to settings and look for Carrier there you can see what carriers are available and make sure you’re not on automatic. Select Koodo. And this will not happen. As Jan Hope says, Koodo is very good on reversing charges. Went through this also last year. No issues.
Userlevel 4
pherman wrote:

What phone are u using? IF u use an iPhone go to settings and look for Carrier there you can see...

@pherman

She has Samsung J3. You go to Mobile Networks and then to Network Operators. When you press on Network Operators it should scan automatically for available Networks. Choose  Koodo manually.
pherman wrote:

What phone are u using? IF u use an iPhone go to settings and look for Carrier there you can see...

Thanks for trying to help. I had already gone to that section and unchecked the roaming but there was no option to deselect the autoscan. Each time I looked Koodo was set, but at some point it must have switched. My husband received a text as well and he didn't even leave the hotel. I can see that Jan Hope seems to think I am being stupid about this but I even got my teenage son to check and there was no where else that we could see to change the settings. I will call Koodo about any charges that have been added and I will ask the store I bought the phone from about the settings. I am back home know and can deal with it. Thanks again for trying to help and responding in a kind and patient way.
Samsung J3. I thought I had changed the settings but I guess it didn't work. I tried to call Koodo this afternoon but gave up after almost an hour. I don't live in Niagara I am in a hotel.
Userlevel 4
Kathleen Keane wrote:

Samsung J3. I thought I had changed the settings but I guess it didn't work. I tried to call Kood...

@Kathleen 

You still have to call them. Next time you have to be absolutely sure that you set it properly before you arrive at Niagara.
Kathleen Keane wrote:

Samsung J3. I thought I had changed the settings but I guess it didn't work. I tried to call Kood...

I was hoping someone would be able to tell me how to set it properly. I will call them again when I get home. Hopefully I will be able to get through eventually.
Userlevel 4
Kathleen Keane wrote:

Samsung J3. I thought I had changed the settings but I guess it didn't work. I tried to call Kood...

@Kathleen

Someone has already told you how to se it properly. Look up to earlier responses.

Reply