Koodo Community

Community

Solved

Phone won't find Koodo network as a carrier.


I was in the US for 3 days and I bought the 3 day unlimited text plan and it worked great. Now that I'm back in Canada, my phone won't find Koodo as a carrier. The only options that come up are AT&T and 302720. It's like my phone doesn't recognize I'm in Canada.

8 replies

Userlevel 7
Badge +4
Go into your settings > general > reset. Reset your network settings, your phone will reboot. All WiFi passwords will be lost, but the rest of your data will be fine.
Ivan wrote:

Go into your settings > general > reset. Reset your network settings, your phone will reboot. All...

Thanks, but this didn't work. The same 2 options come up as carriers.
Ivan wrote:

Go into your settings > general > reset. Reset your network settings, your phone will reboot. All...

do you have any other ideas?
Userlevel 7
Badge +4
Try holding the Power and button at the same time until you see the Apple logo, then release. This will do a hard reboot of the device
Now when I reset the network settings it finds Koodo, but when I turn off data and 3G it drops Koodo and goes back to AT&T. I don't have a data plan and this wasn't a problem before.
Nicole Gingras wrote:

Now when I reset the network settings it finds Koodo, but when I turn off data and 3G it drops Ko...

I can keep it on Koodo, but I loose service if I turn 3G off.
Userlevel 7
Badge +4
Nicole Gingras wrote:

Now when I reset the network settings it finds Koodo, but when I turn off data and 3G it drops Ko...

Koodo uses 3G. That just be on but data can be off It must be on. This has always been the case
Userlevel 7
Badge +4
This image is a bit out of date, but the layout should still be similar. Take note that data can be turned off while keeping 3G on. Just make sure you flip the switches the other way: 3G ON, data OFF. Since you don't have data, you can turn your LTE switch to off as well, if applicable.

Reply