Koodo Community

Community

Solved

No service


I have an iPhone 4s running iOS 8 that started displaying "no service" this morning. My bill has been paid, I've restarted multiple times as well as removed and replaced the the SIM card. Nothing has worked. I have no landline and I live alone so it's going to be challenging to call the help line... What can I do?! This is very frustrating.

15 replies

Userlevel 7
Badge +4
Are you in a place you usually have service? Make sure the phone isn't set to 2g only
Userlevel 7
Badge +4
Your account is in good standing Erin. Try following Paul's advice, maybe turn the phone on airplane mode and off. If none of that works it maybe that the issue is with your SIM card. You could visit the Koodo store in Fairview mall if you still need help.
I have the same problem! iPhone 4s running iOS 9.
Userlevel 7
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Have you shut the phone down, removed the sim card and let it sit for a few minutes before trying again?
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Yes. And reset carrier settings. Updated iOS. Updated carrier settings. Factory reset phone. Not sure what's left.
Userlevel 7
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Have you ever had service in the same location?
Userlevel 7
Badge +4
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Is your 3G enabled?
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Yes, and yes
Userlevel 7
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

I would suggest you go to a Koodo kiosk and explain them your situation, and see if you can get a new SIM card. It may cost 10$, but sometimes they give it for free whenever yours stops working.

Apart from that, I would contact customer support for further troubleshooting steps.
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

I've already visited a kiosk and tried one of their 'active' SIMs. 
Userlevel 7
Badge +4
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Did it work?
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Nope. Nothing has worked so far. 
Userlevel 7
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Have you called technical support?
Userlevel 7
Badge +4
Emilie Schellenberg wrote:

I have the same problem! iPhone 4s running iOS 9.

Providing you've made sure your phone doesn't have 3G disabled, please reset you network settings:

SETTINGS > GENERAL > RESET > RESET NETWORK SETTINGS

Your phone will restart. You'll lose WiFi passwords but the rest of the content on your phone will remain untouched.
Userlevel 7
Badge +4
You could call the help line via the 1-800 number using Skype. But use that as a last resort if we don't find a solution to your problem on the forum

Reply