Koodo Community

No Service

My phone says no service, and I just recently bought a sim card for it. It was working last time I checked. I need help, no phone to call koodo either.

11 replies

Userlevel 1
Have you rebooted the phone? Or removed the sim card and put it back in?
I've done both. I feel like it is a koodo conspiracy because I just bought the phone off my sister (an old koodo phone) and switched from my old blackberry. It was working fine the first day, besides the wifi connection is terrible to get a hold of.
Userlevel 1
I've done both. I feel like it is a koodo conspiracy because I just bought the phone off my sist...Andrew what is your phone? for instance Moto g? Nexus 4?
Userlevel 1
If the Phone is Android. Go into Settings >More>Access Point names> And select Koodo
It is iPhone4s
Could perhaps my other, old blackberry be screwing it up. I didnt take the sim card out or anything. And it is probably left powered on somewhere.. just fyi
Userlevel 7
Badge +4
Did you update the SIM number in Self-Serve? It would not be properly activated otherwise. Activating the new SIM should de-acticvate the old one.
No I haven't. I went to a help desk at a mall to get my sim card and she loaded it for me and said it was good to go. It worked for a day though - unfortuntelly their site isn't working too either: https://secure.koodomobile.com/account/unavailable.jsp
I checked my koodo online and sim card is correct
Userlevel 7
Hi Andrew, If you still have your old blackberry hanging around that had a SIM card connected to that account, try taking the battery out of it or removing the SIM card. There should not be any issue related to it, however I noticed sometimes while switching SIM cards the network can get a little confused with where to send the information. Hope this helps!
Userlevel 3
Hello Andrew,

If you tried all the suggestions mentioned here and still had no luck in connecting to the network, here are some more troubleshooting steps that you may try.

First, deactivate and reactivate your LTE/3G (Settings-Cellular-Enable LTE/3G). 

If it's not working, you may need to reset your network settings (Settings-General-Reset-Reset network settings). If you have a screen passcode you will need to introduce it in order to finish the reset. Please note that this action will delete all your saved Wi-Fi passwords. 

As a last alternative, you can manually choose Koodo as carrier (Settings-Carrier-Select network manually). 

And if it’s still not working, give our tech support team a call at 1-866-995-6636 from another line and our colleagues will be able to further investigate this.

Let us know how this worked for you!