Koodo Community
Question

No messages


I have an unlimited call and text plan but no data. I can't receive any text messages unless I'm on WiFi. I'm using an iPhone 5.

15 replies

Userlevel 7
Badge +4
Hi,
Can you make/receive call? Can you send a test text message to yourself?

If you can only receive message on wifi, that wasn't sms. It might be imessages. Make sure the other people sent to you through the number, and not your iCloud address. iMessages do need data to work, so you would need cellular data in your plan. Also check your settings to enable sms (Go to Settings >> Messages >> send as SMS >> ON)
Thanks for the reply. I can make and receive calls. I can send a test message to myself. SMS, imessage and MMS messaging is on. However when I do not have access to wifi, i can't receive any text messages. My plan states:
Unlimited Canada-wide anytime minutes
Unlimited messaging (text & picture)
even though the plan do not contain a data package.
Thanks ....
Userlevel 7
Badge +4
CorkyLady wrote:

Thanks for the reply. I can make and receive calls. I can send a test message to myself. SMS, imessage and MMS messaging is on. However when I do not have access to wifi, i can't receive any text messages. My plan states:Unlimited Canada-wide anytime minutesUnlimited messaging (text & picture)
even though the plan do not contain a data package.
Thanks ....


As a test. Turn off imessage and try to text someone. See if that works
Thanks Dennis. Turned off wifi on my phone. Turned off imessage. Sent a text and was received ok. They sent a text and I received it ok. I hope that means that my problem is solved.
Userlevel 7
Badge +4
CorkyLady wrote:

Thanks Dennis. Turned off wifi on my phone. Turned off imessage. Sent a text and was received ok. They sent a text and I received it ok. I hope that means that my problem is solved.


Now try with wifi on but imessage off
It also works with wifi on and imessage off. I sent myself a text and it worked OK.
Userlevel 7
Badge +4
CorkyLady wrote:

It also works with wifi on and imessage off. I sent myself a text and it worked OK.


Then it looks like it is your imessage interfering with your text messages.

Can you turn imessage on now and show us a screen shot of your imessage settings?
Don't know how to do a screen shot, sorry, but here is what I got

wifi: on
imessage on
Send Read Receipt: off
Send as SMS: on
Send & Receive: 2 addresses, my email address & phone #
MMS messaging: on
Group Messaging: on
Show Subject Field: off
Character Count: off

Keep Messages: forever
Filter unknown Senders: on
Low Quality Image Mode: off
Userlevel 7
Badge +4
CorkyLady wrote:

Userlevel 7
Badge +4
Turn iMessage off.

You need data (Wi-Fi or Cellular) to use iMessage.

People will only be able to contact you using your phone number. Thos who might have connected using your Apple ID (likely your email address) will no longer be able to contact you.

Thank You so much for your patience and help.
Userlevel 7
Badge +4
For send and Receive, I would only have your phone number in there
Do I do that by going into my settings, messages, imessages, send and receive and uncheck the e-mail address?
Userlevel 7
Badge +4
CorkyLady wrote:

Do I do that by going into my settigs, messages, imessages, send and receive and uncheck the e-mail address?


I think so. I dont have an iphone on me right now so I cant check

Reply