Koodo Community
Solved

new iphone not receiving imessages to phone number

  • 22 November 2021
  • 8 replies
  • 65 views

Just upgraded my iPhone and changed carriers but kept my phone number. Now I can’t receive iMessages unless I text them first. Any idea why?

icon

Best answer by Dinh 23 November 2021, 04:17

View original

8 replies

Userlevel 7
Badge +4

When you said you can’t receive imessage, you meant someone sent you and you didn’t see it on your iphone? Have you tried to reset network settings since you switched the carrier?

Have you completed the number transfer? did you receive a notification from Koodo saying that the transfer is completed? Also, did the old SIM with other carrier work?

Also, when you switch your iPhone, did you move all messages from the old phone to the new one?

Yes. Sent by someone else to me and I didn’t receive it. I purchased a new phone when I switched. I don’t think I got an email from Koodo though!

Userlevel 7
Badge +4

Yes. Sent by someone else to me and I didn’t receive it. I purchased a new phone when I switched. I don’t think I got an email from Koodo though!

They don't send email for number transfering. Normally they sent a text to confirm the completion of number transfer. Did you receive a text from your previous carrier about the number transfer and you responded Yes to it? https://www.koodomobile.com/en/help/moving-your-number-koodo

Yes. I replied “yes”

Userlevel 7
Badge +4

Yes. I replied “yes”

Then there might be some issue with the imessage. I recommend you disable both imessage and facetime in your phone. After that enable it again. Also restart your iPhone. Hopefully it helps.

Unfortunately that didn’t work. I’ll probably have to bring it in to get this one figured out 

Userlevel 7
Badge +4

Unfortunately that didn’t work. I’ll probably have to bring it in to get this one figured out 

If you can pass by an Apple store, they might be able to find out what happened.

Another way you could try is to de-register your message completely with Apple and enable it again with this https://selfsolve.apple.com/deregister-imessage/

Turns out that it was related to something on the Koodo side. All good now!

Reply