Koodo Community

Community

Solved

My international add on for texts doesn't seem to be working in the USA.


I purchased this add on on October 22. " Added* US Unld min/sms $45 30day Price per Month:$45.00 Service effective on October 22, 2016 ." for my iPhone 5S. Now that we are in the States, I cannot send texts unless I have Wifi. My texts want to send as an Imessage and when I change it to text message it still doesn't go. I get a red ! and not delivered message. My Roaming is turned off and my LTE is enabled. What is wrong, please?

10 replies

Userlevel 7
Badge +4
Hello Lori.

If you're making a call, does it work?? Make sure you don't use data because your add-on doesn't include any data!
Yes. It works to make a phone call...

Userlevel 7
Badge +4
Ok, so the problem is not with the service. Does it happen only to 1 specific person? Or to everyone that has an iPhone? Or all contacts whether they have an iPhone or not?
I am home now, so disabled my wifi to try to send messages. It worked now...:/    But this afternoon in the car, it didn't.

Userlevel 7
Badge +4
Maybe it was simply a bug go of the moment. Happy you got it sorted out!

Enjoy your trip
Userlevel 7
Badge +4
Roaming needs to be turned on to access data when travelling outside Canada.

Userlevel 7
Badge +4
She doesn't have data so it's better to leave it off since she doesn't need any data to text!
On another board I found a suggestion to turn off iMessages when away from Wifi. I did that and now my texts send perfectly. Thank you for your suggestions.
Userlevel 7
Badge +4
Lori Lindholm wrote:

On another board I found a suggestion to turn off iMessages when away from Wifi. I did that and n...

Yes, but be careful that you may not receive Messages from your iPhone friends until you turn Messages on again, as the system may hold messages until you reappear on the system.
Userlevel 7
Lori Lindholm wrote:

On another board I found a suggestion to turn off iMessages when away from Wifi. I did that and n...

Turning off iMessages can also take 48 hours to fully turn off as well. I remember when I was making the switch back to Android it took a over a day before I started receiving texts from iPhone users again.

Reply