Koodo Community

Community

Solved

Issues following USA trip


Have two issues here: 1. I travelled to Las Vegas last week and tried to turn my data and roaming off multiple times while I was there. It would turn itself back on though, and each time I unlocked my phone, suddenly I was on AT&T and receiving texts from Canada, despite having jut turned data and roaming off and changed to manual rather than automatic connections. 2. Upon returning to Canada early Tuesday morning, my phone is showing AT&T as my current signal. I have tried turning it on and off again multiple times, but cannot seem to get a Koodo signal and am worried I'm being charged for international rates. I live on the border (sarnia, Ontario) but have never had this issue with koodo before. I'd really like some reassurance that I'm not going t have a $500 phone bill...

4 replies

Userlevel 7
Badge +4
1. Turing off data and data roaming just deactivates data but does not deactivate calls and texts. The only way to deactivate that was to turn on Airplane mode. Changing to manual carriers still wont work since you could not have chosen Koodo at the time so you would have been stuck with Roaming carriers. Note that you will be responsible for all texts (incoming and outgoing while in the US) 2. Since you manually selected AT&T while in Vegas (as it was basically your only options for roaming), you have to manually select Koodo again.
Thanks Dennis. Unfortunately when I go to manually selet Koodo it isn't one of the options. The only two options available are AT&T and Rogers...
Userlevel 7
Badge +4
Michelle Broughton-Rouse wrote:

Thanks Dennis. Unfortunately when I go to manually selet Koodo it isn't one of the options. Th...

make sure your 3G is on. Koodo uses 3G and 4G only. At&T and Rogers also have 2G
Michelle Broughton-Rouse wrote:

Thanks Dennis. Unfortunately when I go to manually selet Koodo it isn't one of the options. Th...

Woohooo! Problem solved - legend! Thanks, Dennis 🙂

Reply