Koodo Community
Question

iPhone X Cellular Data counter at 0 bytes

  • 1 July 2019
  • 4 replies
  • 133 views

Userlevel 2
Hi my iPhone X continually shows 0 bytes used on Koodo’s network which is troubling because some rogue app is using up my cellular data like crazy (used up 4GB while I wasn’t using the phone today).

If I put in a different carrier’s SIM the counter starts to work. I have the device replaced by Apple. I have called Koodo and they say it is an Apple issue. Apple says it is a Koodo issue.

This hasn’t worked on any iPhone X I have tried. Does anyone else have this issue?


4 replies

Userlevel 7
Badge +4
Are you using a jailbreak iphone or using the new Beta ios 13? Did you take the screenshot in black mode?

The black background of the screenshot made me wonder if there was some glitch/bugs in the network settings of your device. What is your Carrier version in Settings >> General >> About?
Userlevel 2
This is iOS 13 but it happened in 12. Since I’ve been using iPhone X models (launch day) this has been an issue. I have used 4 different iPhone X models and have had this happening on all. When I put a t-mobile SIM in the counter works because it is provisioned through carrier settings.

Current carrier setting is Koodo 36.5.7.

Never jailbroken a phone in my life.
Userlevel 7
Badge +4
I didn't notice that on the Xs max or 8 plus or X. I didn't have X with me as of now, but I recalled that issue didn't happen.

Anyway, I would suggest you reset to the factory settings, and with ios 12 and see if it helps. Don't try to restore the phone. Set it as a new iphone and see if is ok.

Here is another link with some suggestions to try https://discussions.apple.com/thread/7695327

You could also try to report the bugs to apple and see what they could do. Koodo is likely doing nothing unless you could prove your issue was something common for many customers.
Userlevel 2
Turns out it was a defective SIM card. Koodo swore up and down it couldn’t be the SIM or their end and it had to be Apple.

So I tried my mom’s Koodo SIM in my phone and sure enough the data counter worked. I went and bought a new SIM card and went through the change SIM process. It works perfectly now.

Reply