Koodo Community

Community

Solved

iPhone won't make or receive calls!


My phone won't make calls! I went a got a new iPhone bc I thought that was the problem, did solve anything, so I went and got a new SIM card and switched the account over. Still didn't fix anything! Then I spent 2 hours on the phone with a tech from Koodo trying to figure out the problem. He still couldn't figure it out! Please help! I can still send and receive texts and use the data but can't make or receive phone calls! This is my business phone, so I am loosing money by the minute because of this

18 replies

Userlevel 7
Badge +4
What does it say when you call?
The call ends immediately and doesn't say anything. I can't even dial *611
Matthew Wilson wrote:

The call ends immediately and doesn't say anything. I can't even dial *611

Yes that's exactly my problem!
Userlevel 7
Badge +4
Did you buy/add a Talk Booster? (Tho *611 still should work) You have "Prepaid" on your product tag.
Userlevel 7
Badge +4
Are you sure your prepaid account is active with an active baseplan?
Yes everything is active, like I said I can text and use data. You can't use those things without a base plan Active! And also the tech guy at Koodo couldn't figure it out. He said he's never seen anything like this. Because we tried everything. I have call boosters and data booster all active and a active base plan!
Userlevel 5
I know a temporary fix. I had a customer a while back with the same issue. No matter the phone, it still came up. Hold the Power/Lock Button and the Home button simultaneously until the screen goes black, then when you see the Apple logo. Release the buttons. It should do the trick, but I only think it will Band-Aid the solution. I always got her phone to work leaving the store but 2 days later she was back with the same issue. My customer never came back after about 3 times of trying so I'm not sure if it was ever fixed or if it's still happening and she's just sick of me not being able to help.
Already tried that! Still didn't work. Thanks though
Userlevel 2
Hi Matthew! Please follow these troubleshooting steps and let us know if there is any improvement: http://support.apple.com/en-us/HT204027. Thank you. ******************************************** If you see a good answer, give it a star.
Already tried all of that. Thanks though
Userlevel 7
Badge +4
Matthew, Try to use a sim from a different Koodo account in your phone and see if the issue happens? Also try to use your sim in another Koodo phone to see if the issue happens. This way we can confirm if it is your account/sim card that's the culprite
Already did that, it's something on koodos end, they sent it to a engineer to deal with.. And said it will take 24 to 72 hours to fix. It still does not work
Userlevel 7
Badge +4
Matthew Wilson wrote:

Already did that, it's something on koodos end, they sent it to a engineer to deal with.. And sa...

Then it is a Koodo system/account issue. It's all on their end unfortunately 😞
When I put my sim in another phone. Same issue. When I put another sim in my phone it worked fine. I also was told to buy a different sim to see if it would fix things when they switched the account over to the new sim. It didnt help.
Userlevel 7
Badge +4
Matthew Wilson wrote:

When I put my sim in another phone. Same issue. When I put another sim in my phone it worked fine...

Yup... clearly its an account issue on Koodo's end
Yeah it's insane! I have never had anything happen to me like this before. Not only am I loosing money from my business but I had to spend time and money to get a new sim and phone. This is driving me insane. I just need my phone to work
Userlevel 7
Badge +4
Matthew Wilson wrote:

Yeah it's insane! I have never had anything happen to me like this before. Not only am I loosing ...

I would send Koodo an email about the costs incurred(getting a new sim , etc) and having a phone and number that does not work. Did you port over recently?
Matthew Wilson wrote:

Yeah it's insane! I have never had anything happen to me like this before. Not only am I loosing ...

I've been having this problem a while, and I turned off my phone and it was fixed by the time it turned on. Probably just a temporary solution, but it may be worth a shot for you if you haven't tried it.

Reply