Koodo Community

iPhone cannot send GIFs or MMS


I have a solid data connection (and WiFi but I don't think that affects messaging) and I cannot send GIFs or photo/text combo messages. I was able to send a photo on it's own via messaging though.

I've tried resetting network settings and double checking the APN settings as well (sp.koodo.com, no username or password).
icon

Best answer by Dinh 29 October 2018, 17:56

Matthew Sauder wrote:

Those were all turned on. Seems like it might just be a messages bug. Since I can send videos I've taken on my phone too, just not gifs copied from either GIPHY or Safari.


It could be issue with MMS from the receiver at other side (you mentioned they were using non-iphone devices). Someone mentioned there was a limit on GIF image size on another carrier (not Koodo but that could be a possibility) https://forums.androidcentral.com/google-nexus-5/351020-sending-gif-via-sms-mms-4.html

View original

54 replies

Userlevel 7
Badge +4
If you can send a picture, then it means you can send MMSs. When sending GIFs, what application are you using?
Userlevel 7
Badge +4
Did u send succeasfully with mms or iMessage? Was it green or blue?
I use GIPHY and also tried copying and pasting one from google as another check. I just tried sending another photo/text combo and that went through though so maybe it only failed before because of trying to send other messages around the same time.
These are all to a non iPhone user so no iMessage.
Userlevel 7
Badge +4
So, if I understand, now it worked?
gifs still won't work, so I can't tell if it's a Koodo error or Apple related.
Userlevel 7
Badge +4
@Matthew Sauder : Have you checked if your iPhone allowed MMS and SMS. Sometimes, it could be the issue. Go to Setting >>> Message >>> Turn ON "Send as SMS" and turn ON "MMS messaging".

Normally they are enabled by default. Also, Both sender/receiver should enable cellular data to receive MMS. I would check it also.
Those were all turned on. Seems like it might just be a messages bug. Since I can send videos I've taken on my phone too, just not gifs copied from either GIPHY or Safari.
Userlevel 7
Badge +4
Matthew Sauder wrote:

Those were all turned on. Seems like it might just be a messages bug. Since I can send videos I've taken on my phone too, just not gifs copied from either GIPHY or Safari.


It could be issue with MMS from the receiver at other side (you mentioned they were using non-iphone devices). Someone mentioned there was a limit on GIF image size on another carrier (not Koodo but that could be a possibility) https://forums.androidcentral.com/google-nexus-5/351020-sending-gif-via-sms-mms-4.html
Userlevel 7
Badge +4
Matthew Sauder wrote:

I use GIPHY and also tried copying and pasting one from google as another check. I just tried sending another photo/text combo and that went through though so maybe it only failed before because of trying to send other messages around the same time.



I wonder if the issue is HOW you are trying to send. If you can take a photo from within the Messages App, or send a photo from your Photos App, then the system is working from Koodo's end.
Userlevel 7
Badge +4
Can you send gifs from #images?

https://support.apple.com/en-ca/HT207179
Dennis wrote:

Can you send gifs from #images?

https://support.apple.com/en-ca/HT207179


Tried that originally too.

I submitted a bug report to Apple as I suspect it's a Messages problem.
Userlevel 7
Badge +4
It's weird since I can send GIFs through my messages app. What iOS version are you on?
Robert T wrote:

It's weird since I can send GIFs through my messages app. What iOS version are you on?


12.0.1, I doubt it's something that affects all users. I might just be lucky.
Userlevel 7
Badge +4
Matthew Sauder wrote:


Robert T wrote:

It's weird since I can send GIFs through my messages app. What iOS version are you on?

12.0.1, I doubt it's something that affects all users. I might just be lucky.


The next step would be to try a restore or factory reset 😖
Dennis wrote:


Matthew Sauder wrote:


Robert T wrote:

It's weird since I can send GIFs through my messages app. What iOS version are you on?

12.0.1, I doubt it's something that affects all users. I might just be lucky.

The next step would be to try a restore or factory reset 😖


Just finished that and same problem. I’ll just wait for 12.1 to see if that helps.

I also tried saving a gif a gif to my photo roll to see if that would help and I got the same result.
Userlevel 7
Badge +4
Matthew Sauder wrote:


Dennis wrote:


Matthew Sauder wrote:


Robert T wrote:

It's weird since I can send GIFs through my messages app. What iOS version are you on?

12.0.1, I doubt it's something that affects all users. I might just be lucky.

The next step would be to try a restore or factory reset 😖

Just finished that and same problem. I’ll just wait for 12.1 to see if that helps.

I also tried saving a gif a gif to my photo roll to see if that would help and I got the same result.


Take your sim and put it in another phone and see if it works
That did work. Probably a problem with my new phone. It’s an XR and I set it up with a backup from my old phone so settings should’ve been the same.
Userlevel 7
Badge +4
Matthew Sauder wrote:

That did work. Probably a problem with my new phone. It’s an XR and I set it up with a backup from my old phone so settings should’ve been the same.


If a restore doesnt work, try the factory reset route
Userlevel 7
Badge +4
I just sent a gif image on my iphone to an Android phone. it worked fine, ios 12.0.1.

I would suggest you try to visit an Apple store, if you believe ios software was the problem.

if you are using iphone XR, you can call Apple suport also, they have 90 days of technical support for the new iphone purchase as standard.
Dinh wrote:

I just sent a gif image on my iphone to an Android phone. it worked fine, ios 12.0.1.

I would suggest you try to visit an Apple store, if you believe ios software was the problem.

if you are using iphone XR, you can call Apple suport also, they have 90 days of technical support for the new iphone purchase as standard.



I tried a factory reset this morning (without restore) and it still didn't work so I'll probably try phone support. I have a trip to Toronto planned in a couple weeks so I could also visit their Apple store for support then.
Userlevel 7
Badge +4
If you do call them, place come back and tell us what the issue was. Very curious
Robert T wrote:

If you do call them, place come back and tell us what the issue was. Very curious


I called and when I mentioned the troubleshooting steps I'd tried they said it could be a hardware issue, though a very strange one. I installed the 12.1 update today thinking it couldn't hurt but it didn't resolve the issue.

I may try to take the phone back to my carrier to see about an exchange but if that doesn't work I guess I'll take it to a certified partner. I could also try their mail in repair program instead.

It's such a silly issue that I hardly care about but after putting in this much work I feel like I need to see it through to the end.
Userlevel 7
Badge +4
Matthew Sauder wrote:


Robert T wrote:

If you do call them, place come back and tell us what the issue was. Very curious

I called and when I mentioned the troubleshooting steps I'd tried they said it could be a hardware issue, though a very strange one. I installed the 12.1 update today thinking it couldn't hurt but it didn't resolve the issue.

I may try to take the phone back to my carrier to see about an exchange but if that doesn't work I guess I'll take it to a certified partner. I could also try their mail in repair program instead.

It's such a silly issue that I hardly care about but after putting in this much work I feel like I need to see it through to the end.


If it was a hardware issue and the Apple agent confirmed, I would ask the Apple agent to take note on your Serial number/IMEI. The next time you visit an apple store, you could ask them to swap.

As the purchase is new within 15days, you could ask for a return and refund with Koodo also.
I'm experiencing the same issue (though with Telus as a provider...someone on their forums actually referred me to here.)

Had a iPhone 6s, upgraded to a XR, and I can't send GIFs via MMS, even though videos and photos work perfectly fine via MMS.

I called up Apple support, and they said that sending GIFs via MMS was removed as of iOS 12. This is a lie, as it was working perfectly fine on my 6S running 12.0.1. Plus, a I'm pretty sure I would have heard about a substantial change like this.

Maybe I'll try calling back and hopefully I'll get a agent who is a little more interested in helping me. Or, the Apple store at Eaton Center isn't totally inconvenient for me to go to...maybe I'll make a Genius Bar appointment and see what they have to say...?

Keep me updated with the status of your phone.

Thanks!

Reply