Koodo Community

Community

Solved

iphone 4s showing no service


my phone says searching and after that showing no service..whats going on? ..i hav done lots of ways,,rebooting,,resting fully,,reseting network,,airoplane mode on and off,,changing carrier,,nothing works,,,u guys facing this problem??do i want to change the sim card to another service connection??is that helpfull??pls help ..do reply

17 replies

Userlevel 7
Badge +4
Did you deactivate 3G network thinking it's cellular data?
Robert wrote:

Did you deactivate 3G network thinking it's cellular data?

yeah i did
Userlevel 3
Robert wrote:

Did you deactivate 3G network thinking it's cellular data?

Hey Dibin! In order to have service in your iPhone, the 3G must be enabled into your Settings. Rest assured, itt won't use data, it will simply allow you to have service to make/receive phone calls and send/receive text messages! Enjoy your weekend! 
Robert wrote:

Did you deactivate 3G network thinking it's cellular data?

Hey karine,,i did that...but no way,, 😞  i changed to another sim ..but it still showing " NO SERVICE " ...u hav the same complaint?? 
Userlevel 7
Badge +4
Check out that first ^^^ I know you say you have rebooted but, Try holding the power button and the home button for 30 seconds until you see the apple logo. and let it boot back up
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

dude this method is great and it worked,,but unfortunately after some time it begans to searching
Userlevel 7
Badge +4
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

It seems to be a universal fix for everything iPhone lol. But if it came back it could be a hardware issue. Have yu tried backing up ur phone and restoring it ? If that doesn't work it may be time for an upgrade.
Userlevel 5
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

Hi there,

Did you follow Chadwick's advice? Let us know if you still need help.

Thanks
Userlevel 7
Badge +4
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

It could also be a SIM card issue.
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

@ Chadwick - nope dude nothing worked,,,i restored it....but nothing works.,,,there is no use in updating ios,.,,i am running 7.1.2 ......ios 8 and 9 users also reporting about the same complaint that we hav .. LOL ..so what shall we do bru ? i changed to another sim card but it still showing " NO SERVICE" LMAO :-) 
Chadwick wrote:

Check out that first ^^^ I know you say you have rebooted but, Try holding the power button a...

@ Nabil - hey dude nothing works ,,there is no use in updating iphone ....and no that ios 7 is best for iphone 4s ...ios 8 and 9 makes 4s slow
Userlevel 7
Badge +4
You need to activate 3G network!

Robert wrote:

You need to activate 3G network!

[img]https://d1qy7qyune0vt1.cloudfront.net/koodo-en/attachment/...

i did that,,,but it still showing no service
Userlevel 6
Hey! Try going in Settings->General->Reset -> Reset Network Settings. This did the trick for me and other iPhone users in the past.  It's important to note that it erases all saved Wi-Fi passwords, so make sure to manually reconnect to your Wi-Fi networks. Let us know if this works 🙂
No way..it did'nt worked..i think iphone needs high cellular range..it does not support low ranges
Userlevel 6
dibin savio jude wrote:

No way..it did'nt worked..i think iphone needs high cellular range..it does not support low ranges

I suggest calling us, and choose option 6 to speak with a representative with our tech support team.  They have additional tools to help you.  Thank you! 
dibin savio jude wrote:

No way..it did'nt worked..i think iphone needs high cellular range..it does not support low ranges

Okay...giv me the number

Reply