Koodo Community

Community

Solved

IPhone 4s No Service in Italy


Purchased the $15 international text package via the self serve app prior to leaving for Italy. Now that I'm here my iPhone 4s won't connect to any of the 4 carriers that show up under carrier in settings. I've got cellular data and 3G on. Just says No Service. Tried turning off and on several times. Please help!

18 replies

Userlevel 7
Firstly, turn your data back off just in case your phone does get a connection. The roaming packages do not guarantee service they only act as a discount when your billing goes out If no networks are showing up when you perform a scan then the problem may just be that no networks are available to your phone. Compatible networks are Hutchinson(3), TIM, Vodafone, and Wind so if none of those have a signal in your area, you will not have service. Make sure your networks will allow 2g if that setting exists.
Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I select either one there is still no service. I just went into self serve and added the $0 international voice roaming add on to see if that makes the difference.
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Please be sure the data roaming and cell data switches are off. Very important And make sure to reboot.
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Ok that did the trick! I know to turn off international roaming but cellular data as well? And turn off "enable 3G"? I'm guessing that if I did need to make a pay per use call I'd just turn on cell data temporarily? Thanks again
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

You don't need data on to send a text or make a call. (just an picture text). Just make sure the two sliders are off to avoid obscene roaming charges.
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Man this is frustrating. So I'm on TIM network, turned off wifi, cell data, 3G and data roaming, but now can't send a message to my girlfriend's iPhone. On wifi they send as iMessages, so I thought that with wifi and the rest turned off they'd revert to plain text messages. I turned iMessage off but that didn't work either. And to think I called Koodo 3 times before leaving to get all this straight! They don't have a clue
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Turn 3G back on keep imessage off as it requires data
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Hey Chad, I tried that but get this ...
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Did you perform the same steps on her phone? I'm assuming you're both in Italy.
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Also try sending her a fresh message. One using her phone number. Even if you have to manually enter it.
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

No, she is back in Canada. Tried manually entering her number but my phone knows it's her, so erased her number from her contact, then tried it. It seemed to send as a (green) text message, but didn't actually send (and thereby get a response) until I turned the wifi back on. I was able to text a friend (send and receive) who doesn't use iMessage - this was with wifi, cellular data, 3G, and data roaming all OFF.
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

After doing a bit of research on this, in the settings of the messenger app of your phone there is an option called "Send as SMS". Make sure that is turned on. When it is turned on, if iMessage fails to send the message it will send it as an SMS however, when it is turned off, if iMessage fails to send the message, it will fail and do nothing more.

Find out more info about this here
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Thanks Mathieu and Chad - I will try that and let you know. I wonder if she would need to remove me from her contacts as well ...? Also wonder - if this works - what will happen when I text her again on wifi. After all, the text package only has 75 outgoing texts. Ideally would be nice to have a wifi/iMessage convo and a non-wifi text convo both on the go - since iMessage isn't flexible enough to go back and forth.
Userlevel 7
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Hey Chris,
After looking into it, my initial solution of resetting the contact would not do anything, please view my new response above and check the settings of the Messages app. This will allow you to send SMS messages and iMessages depending on your connectivity.
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Hi Mathieu. I thought that would be the case as well, so I've had the "send as sms" ON the whole time, but it hasn't worked. When not on wifi they simply don't send.
Userlevel 7
Badge +4
chris wrote:

Thanks Chad. Thing is, the carriers (eg. TIM, WIND, Vodaphone) do show up in the list, but when I...

Try this: https://selfsolve.apple.com/deregister-imessage Use the "no longer have phone" option.

Reply