Koodo Community

iPhone 4 says no service



Show first post

46 replies

ya make sure that your 3G is enabled from the phone as koodo doesn't work on 2G network and as you have checked all other settings, if it is still not working with 3G mode enabled on your phone then you have to apple store if it is still under warranty.
call koodo first, then if they cant do anything call apple @ 1 800 692 7753
I have had the same troubles with my 4s, i selected operator at manual, let it seach, and chose one network fouded. I dont lnow why, but it some area it doesnt work on automatique operator. Enlever le mode automatique dans operateur , laisser cherche 1 minute et choisir un fournisseur trouve. Je ne sais pas pourquoi ,mais dans certaine regions, ca fonctionne pas sur automatique
Also try reseting network settings under General/reset
setting ... general .. reset .. reset network setting only .. and turn on 3g
I have exactly the same problem whit my Iphone 4, and it seems that i'm not alone...It must be koodo because I've done everything to reset my phone and it still not working like before...
Userlevel 7
Badge +4
I have exactly the same problem whit my Iphone 4, and it seems that i'm not alone...It must be ko...Call Koodo technical support at 1-866-995-6636 from any phone (option 6). They will help you out 🙂
Userlevel 4
I have exactly the same problem whit my Iphone 4, and it seems that i'm not alone...It must be ko...When you say "everything," what exactly did you do?
This is an Iphone issue. Had the same problem and ended up getting a new phone from the apple store. Search the problem on the apple community forum website and you will find almost 50 pages of thread on the topic. https://discussions.apple.com/thread/3425746?start=600&tstart=0 While I was waiting for the apple "genius" I brought the webpage up. When asked to explain my issue I simply showed him the website. They replaced the phone no questions asked
It works if only 3 G is on, data can be off.
I got same problem, when I switch my unlocked iphone to another carrier, I just do a factory reset of the phone.
It's 3G enabled?
I have the same problem cellular data and 3G are off Cause on my plan i doesnt have 3G(internet) So when i turn it off right away i lost signal and it apears no service What should i do i've already change my phone twice at apple store
Userlevel 5
I have the same problem cellular data and 3G are off Cause on my plan i doesnt have 3G(internet)...Myke said this 25 days ago and it sums it up nicely 3G = voice/text service. Cellular data = mobile data. Your phone can say enable 3G, or GSM/HSPA/LTE (auto mode) - but the bottom line really is that since Koodo does NOT have 2G networks (voice/text service), that your phone does have to have 3G enabled
Userlevel 7
Badge +4
3G describes the entire cellular network, not just the data portion. Since Koodo does not have a 2G network, turning 3G off effectively prevents the phone from connecting to any network at all. For this reason enable 3G must be set to on. If you wish to prevent access to cellular data, turn off the switch marked "cellular data" on the same page.
Userlevel 5
I'm actually surprised Apple exchanged the phone twice for having 3G turned off.
I switched my husband over to Koodo because it was a much better deal than Rogers and so we could be on the same bill, but he's having trouble with the service on his iPhone, similar to what other people are experiencing. For him it's mostly when he's at home, which I find really weird. His phone is almost 3 years old so I don't know whether it's just getting 'old' or what. He did make sure his 3G is always on after talking to the tech people at Koodo. Why would the service on his iphone be terrible and mine is fine on my Moto G? It doesn't sound like there are any real answers here but I thought I'd give it a whirl.
Iphone reception is something worst then other phone because of the antenna positioned around the phone.
Thats actually easy to fix. All you need is to go to settings > general > cellular > make sure 3G and Data is on. Thanks Erwin!
Thanks all you folks so much sure helped me from senior ..

Reply