Koodo Community

Community

Solved

iPhone 4 problems


My iPhone 4 is no longer sending iMessages on my data only on wifi? It's ever since this IOS7 update

9 replies

Do you have 3G and cellular data enabled? Can you browse the internet with your data?
Userlevel 7
Badge +4
Go to Settings > Messages Try turning off iMessage then turn it back on. You will have to log in with your Apple ID and password again. You should be back up and running again. However, sometimes it takes some time for iMessage to activate if Apple servers are having issues
Yes I've tried and yes I can browse internet and all just can't send iMessages unless wifi connected
Userlevel 7
Badge +4
Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here If iMessage works on wifi but not on data, then internet should be the same issue. 1) If 3G and Data are enabled, Do you have data blocked on your account? 2) I assume Voice and regular texting works on your phone?
Dennis wrote:

Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here ...

No blocks, it started ever since I updated to iOS 7 iMessage only sends as a text rather than iMessage but connect to wifi and it works, my internet works still and I can browse and use apps just iMessage no longer sends on my 3G
Userlevel 7
Badge +4
Dennis wrote:

Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here ...

Try resetting your network settings and try again Settings > General > Reset > Reset Network Settings.
Dennis wrote:

Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here ...

As well I don't receive text from other iPhones even as text unless I connect to wifi it's very annoying
Dennis wrote:

Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here ...

Thanks ! It worked
Userlevel 7
Badge +4
Dennis wrote:

Oops. Sorry I mis-read. Had a big lunch lol It sounds like Cellular data is your issue here ...

Yay! I feel like Batman. *kapow*

Reply