Koodo Community

Community

Solved

iPhone 4...no SIM card message....HELP


Bought iphone4 to replace rather junky galaxy ace 2 my ex bought for my daughter. Galaxy 2 has the $29 monthly plan afaik. Galaxy 2 uses mini sim instead of the micro sim required for the iPhone 4 so I carefully trimmed the SIM card down to the proper size and it seems to fit in the holder just fine. iPhone keeps displaying the no SIM card message at startup. I've tried resetting the network and toggling airport mode on and off to no avail. Also tried a hard reset but nothing seems to make the iphone recognize the SIM card. Anybody have a clue what's going on? Will I just need to bite the bullet and buy a micro sim from Koodo? Oh this iphone is locked to Telus and running ios7 if that matters.

3 replies

Userlevel 7
If you're getting that message and you have 3G enabled with airplane mode off, there could be something wrong with the SIM. I know you said you were careful but the slightest snip could mess it all up. Telus iPhones 4 and up will work with Koodo so that isn't an issue. Was it working before you bought it? Where did you get it from?

I have a SIM cutter at work for emergency situations like this (we run out of micro SIMs for X carrier) which has worked wonderfully so far. I've gotten SIMs to fit in both the Nexus 4 and iPhone 4/4S without any issues but the safest method is to get a properly-sized micro SIM.
Yes it was working just fine with a Telus SIM card. I didn't check the 3G settings I'll have to give that a try. Otherwise I'm assuming I messed up trimming the SIM card and I'll be forced to go get the proper sized card.
Userlevel 7
Badge +4
MikeRichardson wrote:

Yes it was working just fine with a Telus SIM card. I didn't check the 3G settings I'll have to g...

Get someone with a Koodo micro sim to test it. If it work then you messed up. It it also doesn't work then you need to update the carrier settings via iTunes with a working Koodo sim in the phone

Reply