Koodo Community

Community

Solved

I no longer receive service for my Koodo Prepaid mobile phone.


[b]My Phone Problem:
The other day, I was in a rural location near Toronto when I noticed I did not receive service, but then I assumed it was just a service thing, maybe I was a bit too far from their towers, etc,. Getting back home, a place I used to always get service, I do not either. Now I'm kind of scratching my head as to what I'm doing wrong.
The top right corner of my iPhone, which typically displays the carrier (e.g. Telus, Koodo), now simply states "No Service". 

[b]Specs:
iPhone 4s[b]
Unlocked
Koodo Prepaid 1st Plan (15.00$/m for unlimited texting)

3 replies

Userlevel 7
First thing to try is powering down your device and removing the sim card and, if possible, the battery Wait a minute and then reinstall the sim and battery. Restart your device. Didn't work? Check and be sure you're not in Airplane or Flight Mode. Still not working? Navigate to your settings and mobile network settings. Be sure that: Network Selection is set to Automatic USE 2G Only or USE GSM ONLY isn't selected Network type typically should be "GSM\WCDMA PREFERRED" Still not working? Change NETWORK SELECTION to Manual The device will perform a scan which could take up to 2 minutes. You'll be presented with a list of available networks. Choose Koodo or Telus from this list.Note: Doing this disables international roaming. Should you ever want to roam in the future you'll need to change this setting back to automatic If your device still isn't working, check and be sure your bill is paid up and then give Tech support a call. It's free. You can reach Customer Service at 1-866-99-KOODO (1-866-995-6636) or 647-788-4337. Hours of Operation Monday - Friday: 10am - 9pm Saturday: 9am - 7pm Sunday: 9am - 7pm
I'm having the same issue in my own home i get less than 2 bars, where as a month ago I would get perfect service. Have koodo's rural zone's been having service issues?
Userlevel 7
JC nothing wrote:

I'm having the same issue in my own home i get less than 2 bars, where as a month ago I would get...

If you've tried ALL of the above JC, including calling in to report the issue then the only conclusion would be your phone is malfunctioning. If you haven't tried anything above please do. If you haven't called in I highly suggest you do so. Tech support is free and there may be an issue with the tower you'd normally get service from. Koodo / Telus / Bell may not even be aware the tower isn't functioning as it should.

Reply