Koodo Community

Community

Solved

how do I use the texting plan while in the USA


I'm using my Iphone 5 while in the states.  I want to use the $5/100 texts plan.  But I can't seem to send or receive any messages.  Does anyone know what settings my phone should be on?!  I don't want to use data, just send text messages. 

6 replies

Userlevel 7
There shouldn't be anything you have to do in your phone. Your phone should connect to a US carrier automatically. Does it say No service in the top left? Does it say a carrier name? 
Ahmad wrote:

There shouldn't be anything you have to do in your phone. Your phone should connect to a US carri...

It connects to AT&T and has all bars of service.  But messages come either hours late or not at all.  And I can't send messages.
Userlevel 7
Ahmad wrote:

There shouldn't be anything you have to do in your phone. Your phone should connect to a US carri...

First, do a general restart of your phone by turning it off and back on. If things don't work BETTER, then try Settings -> general -> reset -> reset network settings

This will also erase all your previously saved wifi connections/passwords.

It is working, but it's just very delayed on your phone for some reason. There's also nothing more Koodo can do if these don't worry as you're not even on their network.
Ahmad wrote:

There shouldn't be anything you have to do in your phone. Your phone should connect to a US carri...

do you know what I should have my phone settings on though?  Like, data roaming off, cell data on,  imessages on/off, sms/msm messaging??

Userlevel 7
Ahmad wrote:

There shouldn't be anything you have to do in your phone. Your phone should connect to a US carri...

Besides having data and data roaming off, there's absolutely nothing else you need to do. And the data thing has nothing to do whether or not your phone can work (call and text). I have an iPhone as well and go to the states quite often
Userlevel 6
Hey Stephanie! Are your late messages coming from others that you usually chat with through iMessage? If so, this requires a data connection and your phone may not sent/receive the message since it's trying to do it with iMessage. Try going in Settings->Messages->iMessage (off) . Let us know if the problem is fixed! 

Reply