Koodo Community



Hi. I still can't have my Koodo iPhone work in France although I activated the " international data roaming" add-on.

4 replies

Userlevel 7
Badge +4
Did you also activate international pay peruse long distance and international voice roaming? Put your phone in airplane mode and off again. If it doesn't work take out your Sim card put it back in and restart. Make sure you're set to auto network selection. Or in manual let the list populate and pick something with good reception. Alternatively unlock your phone if it isn't already and get a Free Mobile sim. 20 euros gets you 50gb data and unlimited sms/talk.
Userlevel 7
Badge +4
If she did pay for a roaming package, it should be a good thing to have it work. 

While travelling outside the US, there are 2 reasons why you might not get service.

[b]FIRST, since you are outside of Canada no Canadian carrier owns any networks. Koodo relies on the services of local providers. Depending on where you are coverage maybe better than other places. Having no coverage from the local provider may result in you having no service. If that's the case for the whole trip, then you might want to give Koodo a call when you come back to get your money back since you haven't used the service.

[b]SECOND, Have you added the free international roaming package from self serve? Is data roaming enabled on your phone? If you are not in the USA, you require the free International voice add-on be active on your account to connect to other carriers. If you didn't add them prior to your departure, add them (click here to know how) and then turn airplane mode on for 30 seconds and off.

Wish you a wonderful vacation!
Thank you very much Goran and Robert! I also activated the international voice roaming and it now works! X.
Userlevel 7
Badge +4
Happy that you got your problem solved. Enjoy your trip!