Koodo Community

Community

Question

Help Cannot send text message on koodo prepaid sim card


I have an iPhone 5 and a Koodo prepaid sim card that I activated online earlier.  I have unlimited texting and added a 100 talk minute booster.  I cannot send any text messages.  What do my settings have to be for it to work?  I turned off iMessage like the lady told me at Koodo, cellular data is on LTE, nothing works.  Help?

9 replies

Userlevel 7
Badge +4
Was the iPhone originally from Koodo? If not you will have to change the APN settings I believe.
No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo prepaid card last year.  I just got a new card today and activated it.  I also reset the carrier settings.  Cellular data is on, iMessage is off but it says imessage needs to be enabled to send the message.... I'm confused.

Userlevel 7
Badge +4
Natalie Raymond wrote:

No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo...

Pull the Sim, reboot the phone and put it back in. I would give that a try and I'll pass this along and see if anyone else has any ideas for ya.
Natalie Raymond wrote:

No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo...

Tried this option, still not working....
Userlevel 7
Natalie Raymond wrote:

No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo...

Have you turned on iMessage? What happened?
Natalie Raymond wrote:

No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo...

it doesn't work if I'm not on wifi...  says sending but it doesn't send

Userlevel 7
Natalie Raymond wrote:

No it was from Telus but it has been unlocked for a few years.  I used it with another Koodo...

Do this: Then try again

Userlevel 7
Badge +4
From the home screen, tap Phone. If the dial pad is not visible, tap Keypad. Enter *#5005*7672#, then tap Call. What does it show?
Thanks everyone for your help.  I just got off the phone with a koodo technical support guy.  He made me do a reset of network settings again (which I had done before).  Made me turn iMessage off again,   Then he told me to delete the previous conversations that were started in iMessage and start a new one  so that the conversation is a text one and it worked.  As long as I don't turn on iMessage, it will continue to work.  Thanks for your help.

Reply