Koodo Community

Can't connect to mobile network in Malaysia

Since arriving in Malaysia my iPhone searches, then shows "no service" to local networks. I've tried the airplane mode on/off fix and a hard restart. It's not the phone. Another SIM card worked fine on my phone but my Koodo SIM card will not connect. Perhaps there's a block on my account for usage overseas. How can I fix this?

3 replies

Userlevel 7
Badge +4
Sign into self serve and make sure you've added the free international voice roaming add on. Then reboot your phone. This add on is required to connect to any network outside of Canada and the USA.
Userlevel 7
Badge +4
Hello Susan.

Here's how to add the free international roaming packages. There's two of them : 

Connect to sell serve and go to your add-ons

Click to change the add-ons

Search for 1) International Voice Roaming and 2) International Data Roaming

You should now have all those add-ons

Wish you a wonderful vacation!
Thank you. That worked beautifully and am now able to connect to the local networks. I had been trying to do that before leaving on this trip but couldn't find the link to enable the voice roaming. The "Add/remove add-ons" shown as an option in your screen shot wasn't on my self serve page but I was finally able to find it elsewhere on the self serve site. Thanks again.