Koodo Community

Community

Implemented

Wi-Fi Connectivity Workaround - Samsung Galaxy Ace GT-S5830D


Badge +4
This appears to be a common concern amongst Samsung Galaxy Ace owners (including myself) and possibly prevalent with other Android devices, that whenever the device attempts to connect to Wi-Fi, the following messages are received; 1. Scanning... 2. Obtaining IP address... 3. Disconnecting... 4. Scanning... In Method 2, I’ve provided a step-by-step workaround utilizing a static IP address should you encounter this problem. Please note, this workaround may not work for all instances of this problem – two methods are provided. Method One. This method resets/reloads the WLAN or Wi-Fi driver in your Ace. From your dial-pad enter: *#*#526#*#* wait for the following status message to appear. WLANTest Engineering Mode Status... Driver loading successful To exit, tap the Back button. Method 2 -The Workaround. First, go to Settings > Wireless and networks > Wi-Fi settings Tap on Wi-Fi settings and enable Wi-Fi and Network notification. Next, click on the Menu button and choose Advanced. In Advanced mode, scroll down to IP settings and input the following: (Be sure to checkmark the "Use static IP" box before continuing with this procedure). IP address > 192.168.2.130 Gateway > 192.168.1.1 Netmask > 255.255.255.0 DNS 1 > 8.8.4.4 DNS 2 > 4.4.4.4 Tap on the Menu button and choose Save. Remember to disable the "Use static IP" option. For example, if you are only experiencing Wi-Fi connectivity problems with your home wireless router, yet you are able to access Wi-Fi through a wireless router at work - disable the option prior to using the work router. One last method to resolve a connectivity issue with your wireless router is to simply unplug the router until all of the status lights have turned off (approximately thirty seconds or so) then plug it back in. On most wireless routers there are options to specifically assign your device to the wireless router.

66 replies

That's awesome! It fixed my issues. Thanks bro!
Badge +4
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

You're welcome, Thomas.
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

does it have a side effect on phone ? really need to know it
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

not sure what do you mean by a side effect all I know I have been to koodo kiosk in Oakville place Ontario where I bought the phone , they send it for repair or for an upgrade which did not resolve my wi fi connectivity issue, I m not a big wi fi user anyway but the answer I m getting now from koodo its either my internet service provider at home which is bell that could be the issue and I have not try using my smart phone yet a wi fi store aka macdonald etc I should cause the phone is still under warranty until july 2013, I guess my other option is to get a different model phone since what I m reading about this phone is not good regarding wi fi connectivity issue anything else seems fine though
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

Did this and it worked for a while. Now it doesn't. Before it searched for an IP address , now it keeps scanning.
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

trust me diane don't waste your time trying to solve this issue if your phone is still under warranty I would suggest to go to koodo and ask for a different model because from what I m reading here and the time period this issue has been going on , there does not seem to be a solution , which is what I am really disappointed with koodo , they should make a recall and offer their customer an altenative replacement regards renald power
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

I agree but my warranty ended in March. Koodo techs were no help. I felt i knew more than they did. i have done soft resets, hard resets, downloaded drivers, reset my router and the workaround. Nothing works.
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

I hear you that is why koodo offer cheaper rate for taking shortcuts but one dept you cannot take shortcut is customer satisfaction and with this issue they blew it
Userlevel 2
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

Hey Renald, we sell the phones, we do not make them. We cannot offer a recall on them, that would be a decision for the manufacturer to make. Since Samsung is no longer producing the phone, the likelyhood of that happening is slim to none. ________________________ If you see a good answer, give it a star.
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

yes agree but I was to go where I bought it from which is a koodo kiosk I would expect an alternative replacement free of charge this is pro active customer service to you mykec , I understand it is a manufacturer glitch but my advise is take the phone off display and sell something that works sound like the logic thing to do
Badge +4
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

@MykeC, given the feedback and subsequent history of this product/problem (well over a year and the fact that the manufacturer no longer supports the Galaxy Ace), wouldn't it be prudent for Koodo to take the initiative here? While Koodo may not manufacture the device, I think that Koodo has a responsibility to the customer to be forthcoming and to remove the flawed device from store shelves and kiosks, rather than trying to make a quick couple of bucks, while knowingly selling a defective device. If Koodo still wants to sell the device fairly, I think the Ace should be clearly marked [b]DISCONTINUED. This way the customer still has the option to buy the device, but assumes all inherent risks.
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

My speech to text was working since I bought the phone, and now it stopped working this past week.My phone is a Samsung Galaxy Ace S5830D...Have any ideas?? Anybody?? Thanks
Userlevel 7
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

Please repost this as it's own thread in a new topic... It'll get more notice thatvway
ThomasS wrote:

That's awesome! It fixed my issues. Thanks bro!

thank you this is good information
It fixed my first probleym but now i have another .... its says scanning and it never seems to say my wifi is in range when im in my house reasons?
Badge +4
emilynielsen150 wrote:

It fixed my first probleym but now i have another .... its says scanning and it never seems to sa...

Try unplugging your wireless router, wait until all the status lights on the router have gone out, then plug the router back in - you won't lose your security settings on the router. Wait until your wireless router's status lights begin blinking again and try to connect your device using Wi-Fi. Tip. Turn off Bluetooth as this technology will directly interfere with Wi-Fi signals.
I'm having the same problem. I was able to type into the phone keypad *#526# and if I did that 3 or 4 times it would eventually say "unloading Normal driver and loading Mfg driver" and then driver installed successfully and then the wifi would work fine for a little while. It's fine finding my home wifi, but not my work place. very annoying.
Badge +4
HilaryParry wrote:

I'm having the same problem. I was able to type into the phone keypad *#526# and if I did that 3 ...

I hear you. I have included a second method to try, along with some free apps you might want to experiment with. Never encountered Wi-Fi issues quite like this with Android devices, I am continuing to research this issue and will report back to the community with any new findings.
Badge +4
First, go to Settings > Wireless and networks > Wi-Fi settings Tap on Wi-Fi settings and enable Wi-Fi and Network notification. Next, click on the Menu button and choose Advanced. In Advanced mode, scroll down to IP settings and input the following: (Be sure to checkmark the "Use static IP" box before continuing with this procedure). IP address > 192.168.2.130 Gateway > 192.168.1.1 Netmask > 255.255.255.0 DNS 1 > 8.8.4.4 DNS 2 > 4.4.4.4 Tap on the Menu button and choose Save. REMEMBER! To disable the "Use static IP" option. For example, if you are only experiencing Wi-Fi connectivity problems with your work wireless router, yet you are able to access Wi-Fi through a wireless router at home (or vice versa) - disable the "Use static IP" option prior to using the work router. There are also FREE Android Market Apps that will attempt to restore Wi-Fi functionality, they are: Wi-Fi Fixer - repairs connectivity issues with Android Wi-Fi FXR Wi-Fi Fix and rescue - repairs connectivity issues with Android Wi-Fi Wi-Fi Analyzer - Wi-Fi network analyzer Fing - Wi-Fi network analyzer
thanks for the note about the apps, I'll go try them. the issue is a bit weird as the problem has only come up recently. I got the phone at the end of November and it had no problem picking up wifi networks throughout December. It's only recently that it's been unable to connect to particular networks, mainly my work network (I can't restart the router there or use the static IP, I tried, it didn't do anything).
tried WiFi fixer and it had no affect, so I uninstalled it. Now i'm getting a similar but stranger problem. My phone shows that I am connected to wifi with full bars (at work) but I can't access the internert or get my email. I'm going to take it to a Koodo kiosk this weekend and see if anyone there can help me. Unless someone can get back to me first.
I called Koodo on the weekend and reset my phone back to factory default settings to see if it was something that I had done. I had no problem connecting to my wifi at home or my mom's but the problem has come up again now that I'm at work. No one else in my office appears to have this problem, so I'm pretty sure it's my phone. The phone says it's connected to my work's wifi but it's not as I cannot browse to google or get my email. The phone won't scan for networks, for instance right now it says my work's wifi is not in range, but I'm at the office connected to my PC and setting the phone to scan for networks does nothing. if any one else is having similar problems, please let me know what you did.
HilaryParry wrote:

I called Koodo on the weekend and reset my phone back to factory default settings to see if it wa...

I did the reset to factory with Samsung the very next day it did connect to my bell network at home , only to disconnect again a few days later the problem with this reset factory thing is you sometime lose some of your save date aka phone contact etc ,,,it is definetly a problem with this phone right now koodo as not offer to replace it with a different model but since it is on warranty for me I plan on making a request , regards hope my comment help
I just did a factory reset again. I could connect easily to my work's wifi but when I tried to load my google account the connection failed. I plan on taking this phone in for a replacement.
From half an hour its its showing Wlan engineering test. Nothing else happening

Reply