Koodo Community


  • 13 December 2012
  • 5 replies

My phone isnt showing koodo as a mobile network and is connecting to rogers instead, but not letting me use any services besides emergency... I cannot find koodo as a n option to connect to the mobile network.. HELP!

This topic has been closed for comments

5 replies

Userlevel 5
hey Kate what kind of bb is it ? 😛
Userlevel 6
Try: Pulling the battery & SIM then turn it back on Restore the APN settings to Default Ensure Packet Data is enabled
Userlevel 5
Also check to ensure you have 3G services enabled. This can happen sometimes if the phone is set to 2G or GSM only.
Userlevel 7
Badge +4
If only rogers shows up it's a pretty good sign the phone is in 2g only. I think only Rogers actually has a 2g network in Canada.
Userlevel 7
Badge +4
go to Manage Connections Make sure that the option for 2g /3g is selected and not 2g only