Koodo Community

Community

Solved

I can't make or receive calls.


Registered my phone last night and was able to make a phone call. Turned the phone on this morning and I can't make or receive calls. Tried a battery reset (removed and re-installed battery) but the phone still will not call or receive. Blackberry Bold 9930.

10 replies

Userlevel 4
Are you getting SOS at the top right corner? I thought a 9930 is a cdma phone from the USA, no?
Not sure what you mean by SOS. The top right corner shows 2 (of 5) bars and 3G to the left of that.
Ooops - forgot to complete my reply. Yes, this is a USA (Verizon) phone that I'm using as just a phone (data is not compatible) until I get to a Koodo Kiosk (1 hour away) to but a Koodo Moto G (or something).
Userlevel 6
Basil McCarthy wrote:

Ooops - forgot to complete my reply. Yes, this is a USA (Verizon) phone that I'm using as just a ...

Hi Basil, is there a Koodo SIM card in your phone? Verizon phones are usually CDMA phones (without SIM card), which are not compatible with Koodo. Thank you!
Basil McCarthy wrote:

Ooops - forgot to complete my reply. Yes, this is a USA (Verizon) phone that I'm using as just a ...

Yes, I have a Koodo SIM card in the phone.
Basil McCarthy wrote:

Ooops - forgot to complete my reply. Yes, this is a USA (Verizon) phone that I'm using as just a ...

The phone is unlocked. When the agent at the Koodo Kiosk installed a SIM card from a demo phone and tried it, it rang out, but it called with my Verizon number, not the number of the demo phone that she took the SIM card out of. I tried to activate on-line but the website told me the IMEI was invalid. Called Koodo and got it registered with assistance from an agent. It was able to make a call, but I'm thinking now that it made the call with my Verizon #, not my new Koodo #. I've now cancelled the Verizon account and the phone does nothing - no outgoing, no incoming, no text, no e-mail, etc.
Userlevel 4
Under Settings, Network, can you switch the mode to GSM/3G?
Yes. When I change from: Mobile Network - Roaming, Network Selection Mode - Automatic, Network Technology - 1XEV to Mobile Network - Roaming, Network Selection Mode - Automatic, Network Technology - GSM/UMTS, another selection appears, Network mode, which I select 3G. Result is an "X" in the signal strength and my phone indicates it's using my old Verizon number (which is now cancelled) to make the call. When I change the Network Technology to "Global", I have good signal strength but the phone will not make a call, and indicates I'm using my old Verizon #. If I change from automatic to manual, the phone finds a Rogers network but won't call out and shows my old # still. Very frustrating, but I appreciate your trying to help me. Thanks, Basil
Userlevel 6
Basil McCarthy wrote:

Yes. When I change from: Mobile Network - Roaming, Network Selection Mode - Automatic, Network Te...

Hi Basil, at this point, you'll have to contact our technical support directly over the phone. We offer limited support on non-Koodo phones but we'll do our best to make it work! We can be reach at 1-866-995-6636 from another phone, option #6. Rest assured that there is no service fee to receive assistance. Thank you!
Thanks Yannick - tried technical support and they cannot fix this either. I will take it to a Koodo store to see if they can re-configure it. Thanks for your help.

Reply