Koodo Community

Community

Solved

Error Code 10006: "The requested URL could not be retrieved" on Blackberry 9900 using Koodo data network; wi-fi works fine


Anybody else getting an error code 10006 with message "the requested URL could not be retrieved"? For reference, I'm using a Blackberry 9900. It's not a problem with the entered URL (I'm trying to access http://www.google.ca), and I have no problems accessing any URLs while on wi-fi. I used the Blackberry browser on the Koodo network as recently as yesterday. I've done a device reboot. I've attempted to register my device on the network (Options >> Device >> Advanced System Settings >> Host Routing Table >> Register Now) with no effect. Any thoughts? Thanks in advance.

7 replies

Userlevel 1
Do you have the correct APN?
Userlevel 7
You also need to make sure you have a (BB) plan, as that will have the correct provisioning codes for your data to work.
...and as soon as I posted the foregoing, it started working again. It is possible that the network registration worked and simply took some time to take effect. In any case, problem solved (somehow).
Userlevel 7
What plan are you on? Is this a Koodo BB? Do you have a Blackberry Specific Plan?
Thanks MameTozhio and Jonathan I. I've been using my Blackberry on a Blackberry plan with Koodo for almost a year now, so it doesn't appear to be an issue with the data plan. I hadn't fuddled with any of the network settings, so I'm finding it all to be a bit of a mystery. To answer MameTozhio's question, I checked the TCP IP settings from Advanced System Settings prior to posting. Neither "APN Settings Enabled" or "APN Authentication Enabled" were checked, but I left those settings as-is. Thanks again.
Userlevel 7
Cambrone wrote:

Thanks MameTozhio and Jonathan I. I've been using my Blackberry on a Blackberry plan with Kood...

Sometimes it'll just... disconnect and you need to reset it. Not a big deal.
Userlevel 7
Badge +4
I've seen this error before. It seems to be an error in the blackberry browser. Try doing a backup and restore through desktop manager or try another browser.

Reply