Koodo Community

Community

Solved

data problem


I have a blackberry and just changed my plan to CANADA-WIDE TALK AND TEXT PLANS 20$. that should include the pay as you go data right?? my internet, bbm etc doesnt seem to work? my data is on...

8 replies

Userlevel 7
Unfortunately with the older BlackBerry, you need to add a BlackBerry specific plan, you most likely missed the little drop down to change to BlackBerry plans when you were choosing. If I'm wrong and you did choose BlackBerry. Turn the phone off, remove the battery and sim card, and reinsert them. Wait till the phone turns back on and check again. Check self serve. Your plan should have a (BB) at the end of it. If it doesn't you'll need to actually call in to customer service and explain what happened, ask them to change it to BlackBerry and ask them to waive the fee for changing plans twice in one cycle. Let us know what happens. I've attached a picture of the drop down, unless you have a Z10, you needed to choose BlackBerry Curve or Bold from the dropdown Good luck

Userlevel 7
Badge +4
Actually, thre should now be a feature in the add ons section called data saver blackberry access. This is a no charge add on that enables the pay per use data saver to be used with a bb phone (pre bb10).
yeah so i got the pay per use data saver thing. now my internet works when my data is on, facebook does too but if I turn it off and just wanna use wifi nothing works. also bbm doesnt work at all, data or no data...
Miriam you should register your handset with RIM. Options>Device>Advanced System Settings>Host Routing Table. Stay on that screen and tap the menu button and tap on Register Now. Tap OK. You will need to powercycle after that. Your BBM should work after the powercycle.
i tried that and my bbm still wont work and when i turn my data off nothing works 😕 by powercycle you ment take the battery out right?
yes, with the phone on remove the battery and sim for 20 seconds then replace.
did that.. doesnt work 😞
I think you will have to call in then unfortunately. :o(

Reply