Koodo Community
Question

"We're fixing a few things" -- sent to this dead-end page when trying to look at phones/plans.

  • 5 August 2012
  • 3 replies
  • 7 views

I'm looking to switch to Koodo, so I came to the site to look at phones/plans. The front page boasted a smartphone sale, so I clicked "Learn More"... and was shown a page that with the headline "We're fixing a few things," and a short paragraph telling me that Self Serve is unavailable and Reps won't be able to access my account. So I tried clicking on the "Phones" menu item instead; same thing. And the same thing with "Plans." I doubt it's maintenance -- I imagine there would've been notice on the front page, or at least in the blog. I also searched the community for this problem, but couldn't find it. It's been like this since late last night. I've tried several different browsers on both my desktop and my phone.

This topic has been closed for comments

3 replies

Userlevel 7
Badge +4
Unfortunately that's the case. The site is down.
Unfortunately that's the case. The site is down. Ah, thanks! Now I'm just confused as to why they don't have notification up anywhere.
Userlevel 2
Hey Folks; Our systems are going through some maintenance today so not everything will be available. If you have any changes that you want done, I recommend waiting until tomorrow to do them. You did receive a notification when you saw "We're fixing a few things". Have a great day 🙂.