Koodo Community

Community

Solved

Not Found error when clicking "Pay my bill"


This always worked in the past, but today after logging in to self serve I navigate to the billing summary, and when clicking "Pay my bill" I only get an error page with the message "The requested URL /account/selfserve/postpaid/credit_card_payment was not found on this server." I tried with cookies deleted and cache cleared, using Chrome and Firefox, all the same result. How can I pay my bill when the Web site is broken?

3 replies

I have the same issue and it looks like many people do as well.  No solutions seem to be available except cleaning cookies and trying different connections which we both have done.  No one seems to have an answer.  I suspect it has something to do with individual accounts.  But when I try to register for a new account i get the same 404 error page not found.
Your login is setup as a manager and not the account owner. You'll need to call customer service so they can fix it from their end.  Just found this answer out.  I wish they'd put this in a faq it seems it happens to enough people.
Userlevel 6
Hi Joachim, were you able to access your Self Serve account? Keep us posted 🙂 Thanks! 

Reply