Koodo Community

Community

Solved

Incorrect Plan


Hi there - was just checking out and making a payment on my account and noticed that my monthly charge is $40...I believe it should be $36 as I brought my own phone...can you help?

8 replies

Userlevel 1
Did you account for tax? That is the only fee not included in the plan price
Hi there - yes, this is before tax. the Monthly amount shows as $40.00 with tax (for this bill, which also includes some time for last month as I just started with Koodo and this is my first bill) at $6.93.
Userlevel 2
On page 3 of your bill, there is a breakdown of the charges. You should see an item "SIM only 10$ discount". If you do not see this, you should speak to customer service to see why it was not activated on your account.
Thank you - there is no line item for SIM only $10 discount. That said, if I call customer service there is a $35 charge as I'm a monthy customer...
Userlevel 2
Lindsay Wight wrote:

Thank you - there is no line item for SIM only $10 discount. That said, if I call customer servi...

It should read "SIM only 10% discount"... not 10$ -- big difference! 🙂 If there is a billing error, then you will not be charged for calling customer service. You will only be charged a fee if you are calling to do something that can be done via Self Serve. A billing error cannot be fixed through Self Serve.
Userlevel 7
Lindsay Wight wrote:

Thank you - there is no line item for SIM only $10 discount. That said, if I call customer servi...

No you won't! If you are calling to discuss your bill then you won't be charged for it
Userlevel 6
Lindsay Wight wrote:

Thank you - there is no line item for SIM only $10 discount. That said, if I call customer servi...

Can you not add the 10% discount for bringing your own phone online?
Userlevel 5
Lindsay Wight wrote:

Thank you - there is no line item for SIM only $10 discount. That said, if I call customer servi...

When I went though it a couple of months ago the option wasn't online Chris, I had to call in. Rep didn't know it was an option and had to look it up and ask for help putting it on.

Reply