Koodo Community

Can I enable data only for picture messaging?

  • 25 August 2012
  • 4 replies

So I have the $20 plan with the $5 unlimited picture and text messaging add on. However I'm not able to receive mms files. I press download and it says "downloading" forever. I have searched through the koodo community website and found out that I must have data enabled for it to work. However I'm concerned that if I enable data I may experience data charges from background applications running. Is it possible to enable data exclusively for mms access? Is there an app for that? Something that allows me to use mms without suffering data, or something that denies data access to background applications. This is for a Samsung Galaxy S II X

This topic has been closed for comments

4 replies

Userlevel 5
To the best of my knowledge there is no way to do that or any app that would help. One thing that might work is if you were connected to wifi at the time, and then enabled your data you should be ok. Any apps or processes trying to get on the internet would use your wiif, while you would be able to picture message over the cell network. If this works remember to turn off your data again when done to avoid using data on the cell network.
Userlevel 2
Hey Steven; As far as I know, there isn't a way to just restrict data to MMS. Once you turn the Mobile Data on, any apps that require a connection that are currently running will access the data. I recommend making sure that all possible apps are turned off/closed out of before enabling data. This would include email apps as well. Keep in mind, you may still incur data usage even with taking all of the precautions. Perhaps the data saver lightweight would be the best route to go. That way you can keep your bill low and not have high pay per use data charges. Have a great day 🙂.
Userlevel 7
Badge +4
SmartApn does exactly what you're looking for. Connect to play market with wifi and search for it or follow this link. https://play.google.com/store/apps/details?id=com.tobwithu.smartapn&hl=en&referrer=utm_source%3Dgoogle%26utm_medium%3Dorganic%26utm_term%3Dsmartapn+3g+off+mms+on
go to your apn settings on android (or use iphone configurator on iPhone) and change your apn to consumer.koodo.com This will restrict data to MMS only.