Koodo Community
Solved

Wrong Time Zone


I just got the new Samsung Galaxy SII X a couple days ago and after day light savings my phone wouldn't change to the right time. I found out it was on auto time zone but it thinks I'm in a different time zone than I actually am even though I clicked the correct one. Is anyone else having problems with that or know how to fix it?

6 replies

Userlevel 7
Badge +4
Hi Shadow, Actually I did read a few times in these forums today that some people had trouble with the timezone, so you're not alone. Did you try these suggestions: reboot the phone, or set the timezone manually and then back to automatic? If none of those work, I'm not sure what it might be!
Sophia wrote:

Hi Shadow, Actually I did read a few times in these forums today that some people had trouble ...

I did try rebooting the phone, and manually changing the timezone then back to automatic. And when I changed it manually it would work, until it was locked again at which point it would go back to the wrong time. If I deselected the auto time zone button it works, but I don't know how to make it know my time zone.
Userlevel 7
Badge +4
Sophia wrote:

Hi Shadow, Actually I did read a few times in these forums today that some people had trouble ...

Do you often move between time zones? I'm not understanding why you need to switch back to automatic.
Sophia wrote:

Hi Shadow, Actually I did read a few times in these forums today that some people had trouble ...

Not enough for it to be a huge issue. But it is a feature I would like to have and I would like to have working since it is there. It's not the end of the world if it doesn't work but if someone knows how to fix it I'd love to know.
I posted 3 days ago with the same issue "In the wrong Time Zone".
Honestly, I have the same phone, had the same issue for days. Finally just went and turned off "Automatic Time Zone" and set the timezone myself to Eastern Daylight Time, No more problems. Probably the phone or the network hasn't been properly changed to switch at the correct date.

Reply