Koodo Community

Community

Solved

wifi will not turn on


Samsung Galaxy S4. Wifi will not stay on. When I touch the wifi switch, the slider goes to the right (on) position. However, after a few seconds, the slider returns to the left (off) position by itself. Tried rebooting but that didn't help.

7 replies

Userlevel 7
Badge +4
Try factory resetting the device. I know a few people who had that problem and it was fixed. But its a process so back up everything. And then dedicate some time to setting your phone back up. Its easy just follow the instruction's Best of luck.
Userlevel 7
Badge +4
Try removing the battery.

You're not the only one. Here's a list of people complaining / trying to find solutions http://forums.androidcentral.com/samsung-galaxy-s4-active/294093-please-help-my-galaxy-s4-won-t-let-...
Thanks for the tip. First step was battery removal. Not successful. The fellow at the local Koodo kiosk transferred the data to a spare S4, then did a factory reset. Not successful. I took it to a cell repair shop. The technician there said it was a pooched motherboard. Replacement would be about $150. If that is the case, then I may be better off retiring it and going with a newer model.
Userlevel 7
Badge +4
Les wrote:

Thanks for the tip. First step was battery removal. Not successful. The fellow at the local Koodo...

I concur. I wouldn't spend $150 to repair a phone of that age. If everything but WiFi works, I'd keep it as a backup device, but I'd look to replace that phone. Most midrange phones available today can give you a better user experience than the S4, without costing an arm and a leg.
Les wrote:

Thanks for the tip. First step was battery removal. Not successful. The fellow at the local Koodo...

My s4 started doing this did the battery and it fixed it for a little bit... but now its doing it again.. thanks for the help
do not send me any of this koodo community forum
Userlevel 7
Badge +4
khalil attia wrote:

do not send me any of this koodo community forum

Click on your profile and disable e-mail notifications!

Reply