Koodo Community


WiFi isn't working at home despite apparent excellent connection. Help!

Userlevel 1
I am a Koodo Prepaid customer with an HTC Desire 320 phone. 

I am unable to do things via WiFi that were previously working fine. The problem started yesterday evening.

When I go into Aquamail, it says "persistent incoming server errors". There is also a timestamp beside this message that says "!July 17,18:00" which roughly coincides with when my problems began. When I have Aquamail check the email settings, it claims to detect errors with both the incoming and outgoing mail servers.

I  play an online scrabble game called Words By Post which typically involves several simultaneous games. When I try to see if it is my turn in any of my games, it says "Loading...." goes away for a long time and comes back with  this error: "Oops.We were unable to connect to the server. Please check your network connection and try restarting the app."

These errors would suggest a connection issue. I'm at home using my WiFi. My connection name is Balmer and the phone says I'm connected and the signal strength is almost always 4 out of 4 occasionally dipping momentarily to 3. (I sit less than a meter from the router.)  The phone says the signal strength is Excellent and the link speed is 65 Mpbs.  My laptop uses the same WiFi connection and works perfectly. 

I'm baffled. Why does the network work fine with my laptop but not with the phone?

I've tried "forgetting" the Balmer  network  on the phone and then reconnecting to it but that didn't help at all.

There is one other factor that comes to mind because of the timing but  I can't believe it is relevant because the laptop is working fine wirelessly. I had a VOIP phone service  that was connected (correctly) to the network and disconnected it yesterday afternoon/evening at roughly the same time this trouble began. I simply disconnected the phone adapter from where it sat between the modem and router and  connected the router back to the modem as it had been before I got the VOIP service.  I powercycled the modem and  router and, as I've said, the laptop is working just fine. I can't see how the presence or absence of the VOIP adapter would be a factor unless the laptop were having the same problems as the phone. Still, it's the only substantial change I made to my setup since I got the cell phone and I made it at roughly the same time the problem began so maybe it *is* a factor....

I would really appreciate some help with this. 

By the way, I'm confident that the phone is okay. I was over at my friend's place yesterday afternoon and was on his WiFi; my game (Words by Post) worked fine there and I was able to do Google Voice searches without difficulty. I think I also checked email there and had no problems.

6 replies

Userlevel 7
Are you sure you were on wifi at your friends house? Can other devices use your wifi ? Have you power cycled your phone?
Userlevel 1
Yes, I'm certain I was on my friend's WiFi when I was at his apartment. He's five or six blocks from my place (way too far for me to be on my own connection) and I set up the connection to his WiFi while I was there yesterday for the first time.

I'm quite computer-literate but this is my first cell phone so I'm still learning some basic concepts. When you say "power-cycled" in the context of the phone, do you mean something more than just hitting the power button momentarily? Because that's all I've ever done with this phone: tapped the power button for a moment. Since I still hear notifications for texts, game moves, and phone calls after I've done that, I assume that I haven't actually power-cycled the phone since I got it two or three weeks ago: I *think* I'm in the equivalent of "sleep" mode for Windows. I think you're talking about the equivalent of a Windows shutdown.

How do I power-cycle the HTC Desire 320? I don't see this covered in the manual. Hmm, in a spirit of experimentation, I just held the power button down for a while and got various options, including Restart and Power Off. First, I did a restart  but after getting back to the desktop (or whatever it is called on a phone) I'm getting the same errors in my game and email; connection still shows as Excellent in my WiFi settings.  Then, I did the Power Off option, waited at least two minutes, and booted the phone again. That didn't fix my problem either.

What else can I try?
Userlevel 7
Are you successful in having other devices connect via wifi? Does your router offer push-button wps?
Userlevel 1
Chad Burr wrote:

Are you successful in having other devices connect via wifi? Does your router offer push-butto...

As I've said, my laptop connects to the WiFi just fine. That's how I'm communicating with you now. I've seen references to this one-button setup for wireless devices but my router doesn't have that feature. It's a Linksys WRT160Nv2. 
Userlevel 7
Badge +4
I suggest following the steps you used at your friend's house to reconnect your phone to your own Wi-Fi. Sometimes they 'forget'. You speak about a modem and a router. Is it possible your Wi-Fi signal strength on the phone is from a device not actually connected to the internet? Are you able to connect directly to the gateway device provided by your ISP?

What happens if you reconnect the VoIP device as it was?

Userlevel 1
The very good news is that the phone is connecting again. My game plays normally and Aquamail is no longer showing the errors  it was before. 

The bad news is that I can't quite explain it.  As  I reviewed my setup I discovered one key error: the ethernet cable from the modem to the router was wrongly  connected. It was in the ethernet port on the modem but in the dim light where the modem and router sit, I had mistakenly plugged it into Port 1, not Internet, on the router. After I moved that cable  to the Internet port on the router, and powercycled modem, router and phone, my network connection on the phone was working fine. 

What mystifies me is how the laptop was working wirelessly when I had the ethernet cable wrong! How could my wireless work if the router was not getting the ethernet feed from the cable modem? It seems to me they should have BOTH failed to work wirelessly under those circumstances. And no, I could not have been on the neighbour's wireless: every wireless network that I can "see" is secured and mine is the ONLY one that I have the password for.

Well, I'm not going to dwell on this. By some magic, the laptop DID work well enough for me to post my question despite the critical mistake in the cabling and I managed to ask the questions I posted. The answers I got here finally got  me looking in the right place and now everything is working as it should. I thank you both for that!

Best regards!