Koodo Community

Community

Solved

Wifi connection active but no data - samsung ace 2


I have a prepaid samsung Ace 2 without a data plan. This is a new phone that was activated this weekend and the issue I am having has been happening since I activated the phone. I am not able to connect to the internet in any way with the wifi. I am able to connect to my home network on wifi, use kies wirelessly using the wifi, and send and receive mms photo texts. Data is enabled under "settings-wireless and networks-mobile networks" so I'm puzzled why I cannot get a data connection on wifi. Anyone have suggestions?

9 replies

Userlevel 7
Try resetting your router. Unplug it. Wait five seconds and plug it back in.
Userlevel 7
If you find that doesn't work, try doing a hard reset of your phone by taking the battery out while the phone is on, (sim card can stay in as the sim card won't affect the capability of connecting to wifi) leave it out for 30 seconds to a minute and put it back in. That should help get everything working properly on your phone side of things. Hope that helps 🙂
Thanks guys. Tried both but neither resolved the issue. The wifi connection shows as active, the signal is strong and the icon shows that it is attempting to transfer data. It simply does not connect with any internet based app (youtube, play store etc). I know the google account is good because we tested it on an ipad and laptop. All the other wifi devices in the house are functioning properly so I'm at a loss. It all points to the data being blocked on the phone by a setting somewhere but then the mms photo texts should not be working if that was the case. Hopefully someone knows of a setting that I am missing somewhere.
Userlevel 7
Have you tries forgetting the network on your phone and reconnecting to it as a new network?
Badge +4
To be honest, I would recommend ditching the Ace 2x. The Ace 2x is an older device and has had problems accessing Wi-Fi. I ended up having to make my Ace 2x a preferred device on my wireless router using MAC address filtering. Wi-Fi should work right out of the box and you shouldn't have to go through any special steps to get it to work. As a last resort, a hard reset (or factory data reset) may get Wi-Fi working again. The steps that Daniel describes is a soft-reset. This fixes issues such as frozen apps or an unresponsive device. A hard reset wipes the device completely, but leaves the microSD card intact (if installed). The reset restores the phone to factory default settings and may restore Wi-Fi functionality. To perform a hard reset go to: Settings > Backup and reset - tap Factory data reset. If you're still not able to get Wi-Fi to work, I would recommend returning the device (you have 15 days from date of purchase) and pick up a Moto G instead. I have the Moto G as well and Wi-Fi on that device works flawlessly. It's available on prepaid at stores like Walmart.
Userlevel 7
As Rikkster says, if you have tried the other options that have been suggested, you should do the factory reset, be sure to back up any data that you do not wish to lose and start again. Many people have had issues with Ace 2X and it's not pretty, if you can return the phone and get another one, the Moto G is a great quad core phone that surprises many, or you can try the Nokia Lumia 635, it's been given good reviews from most of the Mobile Masters for what I've seen on here so that shouldn't disappoint either. Hope that you get the issue resolved and if not, you have a couple really good phones to choose from 🙂
Thanks for the suggestions folks. I think I have it resolved and it sounds very similar to Rikksters solution. It appears there is a DHCP configuration issue between the phone and my router. If I configure a reserved IP address on my router for the phone (using the phones MAC address) then configure that reserved address as a fixed IP on the phones WAP settings (rather than letting DHCP set everything) it is able to connect to the internet. If I let DHCP configure the WAP settings then I do not have access beyond my LAN. I haven't tested it on any other "free" networks yet so I can't confirm if the issue is with my router or the phone but at least I have isolated the issue to a network setting problem. FYI - Even though I resolved the matter, I took the advice offered and returned the Samsung Ace for a Moto G.
Userlevel 7
Good to hear you got it resolved, but it's good you decided on a different device, the Moto G will not disappoint. Enjoy! 🙂
Thanks. I thought I would post the resolve/work around just in case someone else has the same issue and does not have the option to exchange the phone like I did.

Reply