Koodo Community
Question

Wifi calling not working - Samsung S10


Like it says in the descriptor I can't get Wi-Fi calling to work on my S10.

Firmware is up to date, and VoLTE is enabled.  I registered with Koodo for the service, and the Enable Wifi Calling button in my phone settings is enabled.

When in Airplane mode and wifi is turned on, I get a message saying that I have to exit airplane mode to make the call.

It's important for me to have this feature working. I appreciate any help you can give me.


11 replies

Userlevel 7
Badge +4

I don’t think Koodo’s goal with wi-fi calling is being able to make calls with Airplane mode being turned on.  That would mean you won’t use minutes when you’re over wi-fi, therefore you could go international, turn on airplane mode and make calls. That doesn’t mean wi-fi calling doesn’t work. 

Do you see the wifi calling icon when you’re in low coverage areas? If you do, then it works.

 

That's an interesting point. So I can't see if wifi calling is working until I'm remote somewhere?

I'm going to work in a remote location in two weeks. Last year everyone was using wifi calling but me. I'd like to be sure it works before I go.

 

Userlevel 7
Badge +4

I have noticed that wifi calling doesnt seem to connect on a regular basis.  Im working from home and connected to my wifi and I currently do not see my wifi calling connected, even though it was connected before.

 

Were you able to successfully register for wifi calling on your phone?

Yes, successfully registered for it.

 

Userlevel 7
Badge +4

Do you ever see the wifi calling icon that Robert posted?

Nope. Nevee see the icon.

Userlevel 7
Badge +4

Nope. Nevee see the icon.

That’s weird.  It usually shows up when you first register.  If you never seen the icon, it means you may have never connected to wifi.

 

Are you connected to a good wifi source right now?  maybe you can turn off wifi calling in your phone app setting and re-register.

Oh yes, ive a great wifi connection and I've registered for wifi calling a half dozen times.  No difference. Have never seen that icon.

Userlevel 7
Badge +4

Oh the wifi calling icon just randomly popped up on my phone. Um... Try restarting your phone? 

Userlevel 7
Badge +4

Turning On Airplane mode and turn on Wifi should be the easiest way to test if Wifi Calling working or not.

In your case, you mentioned it worked before? and you used the same phone?

Also, is your Internet provider one of the providers listed below?

  • Access communication
  • Sasktel
  • Bell Aliant
  • Eastlink
  • Xplornet
  • Northwestel

Telus (parent of the Koodo brand) noted they had wifi calling issue with them https://www.telus.com/en/bc/support/article/wifi-calling-faq

Userlevel 7
Badge +4

That's an interesting point. So I can't see if wifi calling is working until I'm remote somewhere?

I'm going to work in a remote location in two weeks. Last year everyone was using wifi calling but me. I'd like to be sure it works before I go.

 

Not exactly. I juste tested on my phone and got the icon when I put airplane mode on. So forget what I said. The only truth is that, usually the icon pops off when you’re in low coverage areas, yeah.

Reply