Koodo Community
Solved

Wi-Fi Calling Hell -- Galaxy S9+

  • 29 March 2021
  • 2 replies
  • 60 views

Wi-Fi calling feature is absolutely critical for me. I’m a first responder and have to be on call 24/7. We have no service at home (we used to, but Telus “upgraded” the tower and now we don’t), but we have fiber internet and wi-fi. I bought a Galaxy S9+ specifically for the wi-fi feature. When I try to turn it on it says I have to be in cell range to turn it on (WTF? I’m turning it on because I don’t have cell service, obviously). So I go into town and get service, and try to turn it on and it says I need to be on my wi-fi network (WTF? I’m not at home with my wi-fi obviously). So I used a booster at home and managed miraculously to get a signal and turned wi-fi calling on. And now it simply cancels me out of wifi calling whenever it feels like it and doesn’t tell me, jeopardizing people’s lives because I’m missing call-outs. And I can’t turn it on because I need to be in cell range. Like seriously… WTF?!?  I call tech support and they say they can’t help me because it’s my phone and I didn’t buy it from Koodo. The whole point of being mandated by the CRTC to support any phone is to avoid this crap. So people’s lives are at risk and Koodo won’t help me and Wi-Fi calling feature is absolutely idiotic because it requires me to have cell service to get it and simultaneously be at home. What on earth am I supposed to do? What an idiotic mess.

icon

Best answer by Robert T 29 March 2021, 14:33

Unfortunately, since it's not a Koodo phone, this kind of problems may happen.  You might wanna check your router settings in order for you not to be disconnected of Wi-Fi calling every time.

In rare cases, your internet service provider (ISP) may affect your ability to connect. If you are not able to connect through the following ISPs, you can change the DNS IP address of the Wi-Fi connection on your phone to Google public DNS IP address: 8.8.8.8 & 8.8.4.4 and try again. Please contact us if you are still not able to connect after the DNS change

View original

2 replies

Userlevel 7
Badge +4

Unfortunately, since it's not a Koodo phone, this kind of problems may happen.  You might wanna check your router settings in order for you not to be disconnected of Wi-Fi calling every time.

In rare cases, your internet service provider (ISP) may affect your ability to connect. If you are not able to connect through the following ISPs, you can change the DNS IP address of the Wi-Fi connection on your phone to Google public DNS IP address: 8.8.8.8 & 8.8.4.4 and try again. Please contact us if you are still not able to connect after the DNS change

Badge +4

Why not opt for a third-party VoIP provider? 

Fongo Mobile is one example. It works over Wi-Fi and it doesn’t matter which smartphone you use. There are other VoIP providers out there so you may want to shop around. Koodo’s Wi-Fi Calling feature is essentially a VoIP line as stated under Koodo’s Wi-Fi Calling Requirements; A Wi-Fi connection that allows Voice over IP calling (VoIP).

https://www.fongo.com/fongomobile/

https://www.koodomobile.com/en/help/wifi-calling

The downside to some third-party VoIP services is that some may not auto-reconnect to cellular (Koodo’s Wi-Fi Calling does) and you may have to pay a little extra for additional features. 

Reply