Koodo Community

Community

Solved

Why will my new phone not recognize Koodo SIM card?


I have been using a Moto G phone from Koodo but recently bought a Black view Ultra A6 (from China) hoping to use the dual SIM when I travel to India. However, when I put the SIM from my Moto G inti the Blackview, it recognizes the card as being from Telus but will only allow emergency calls and doesn't connect to the network. Could this be a bandwidth problem? Or a 2g vs 3g issue? Any help would be appreciated! Thanks!

13 replies

Userlevel 7
Badge +4
Check to make sure the China phone will even be compatible on the koodo network here. www.willmyphonework.net koodo also has an IMEI checker on self serve FAQ section.
Thanks for replying. I checked the IMEI and it said it should be compatible.
Userlevel 7
Badge +4
Hannah wrote:

Thanks for replying. I checked the IMEI and it said it should be compatible.

Put the phone into and out of Airplane mode with the SIM in the phone. Also try rebooting the phone without the SIM in it, and then put it back in once its booted up. You may also have to change the APN settings on the phone to match Koodos network.
Userlevel 7
Badge +4
Make sure you check this on the China phone

This list is from Timo( a Mobile Master and Genius) lol Tap the menu key.
Tap System settings.
Tap More...
Tap Mobile network.
Tap Access Point Names.
Press the Menu button
Tap New APN:
Name: KOODO
APN: sp.koodo.com
Proxy: 74.49.0.18
Port: 80
Username: leave blank
Password: leave blank
Server: leave blank
MMSC: http ://aliasredirect.net/proxy/koodo/mmsc
MMS Proxy server: 74.49.0.18
MMS Port: 80
MCC: 302
MNC: 220
Authentication type: No set
APN type: No set
Tap menu key, then tap Save.
Tap the radio button at the right of the Koodo APN to activate data services.
Tried airplane mode on/off as well as configuring the APN settings (which were correct). I just restarted it but still nothing. So strange!
Userlevel 7
Badge +4
Hannah wrote:

Tried airplane mode on/off as well as configuring the APN settings (which were correct). I just r...

Make sure the sim is still working in the other phone. I'm not sure why its not working if u have checked all these things. It might just be that's its not compatible after all.
Hannah wrote:

Tried airplane mode on/off as well as configuring the APN settings (which were correct). I just r...

Maybe not 😞 The SIM works in my Moto G so it must be the Black view phone I guess. I emailed the "Will my phone work" people since they didn't have my sub model listed so we'll see what they say. Thanks for your help!!
Hannah wrote:

Tried airplane mode on/off as well as configuring the APN settings (which were correct). I just r...

Allow digital sync development community room Google approved my accurat
Userlevel 7
Badge +4
Hannah wrote:

Tried airplane mode on/off as well as configuring the APN settings (which were correct). I just r...

MD Tonmoy Khan..please stop spamming every post with this comment.
Badge +4
If I'm not mistaken, one of the slots defaults to 2G on dual-SIM model devices. Koodo does not operate a 2G GSM network. Of the network specifications I'm looking at, the phone doesn't appear to be compatible with Koodo's 3G network. The manufacturers' site lists 900/2100 MHz for 3G. For Koodo 3G, you need 850/1900 MHz.
OK that must be why. Thanks!
Userlevel 7
Badge +4
Hannah wrote:

OK that must be why. Thanks!

Glad its sorted. Sorry that ur phone will not work properly on the network.
Userlevel 4
I have been tempted many times to buy a phone in China (gearbest.com), they are much cheaper, but when you check the specs you find out that those phone do not comply with the North American system. Also Amazon is occasionally selling phones that do not match the frequencies or match only partially the frequencies used by providers in America. So peel your eyes and make sure that the nice little phone you fall in love with will work here.

Reply