Koodo Community

Community

Solved

Why is my data not working?


I bought a Samsung 4, 3 or 4 months ago and upgraded to a plan with 50GB of data. My data usage is zero so I should not be blocked. I checked my IMEI with the tool and everything is compatable. My Mobile data is turned on. I'm not in airplane mode. I've removed and reinstalled the battery twice. When I bought the phone I told the guy I probably would never use data. But now I want to use it.
    When I turn on my phone I get a message that says  [i]I have undelivered messages that will be sent when a service is available. I think these are 2 photos that I tried to send via text message last week.
   When I start Internet explorer I get a message saying No mobile network available.  I can use the phone to make calls.
     How do I get my data to work? 

9 replies

Userlevel 7
I suggest you check your plan details again because Koodo doesn't offer a plan with 50gb of data.

That being said.

Make sure your data is turned on

Settings... Wireless and networks... Mobile network....

Data enabled

And check to be sure your access point names are set for Koodo.sp Here is an article about the correct settings http://mobilemasters.koodomobile.com/...

Thirdly, are you sure a data block isn't on your acct? Check plan details in self serve.
Userlevel 2
Everything about this sounds.....strange. A 50GB data plan? That doesn't exist. Internet Explorer on a Samsung Galaxy 4? Doesn't exist.
Nope it's not working. My new $35 Plan includes data.
   Settings -- Data Usgae -- Mobile data is checked.
  Access point name is Koodo.sp ---  sp.koodo.com
  IMeI is good.
  I've taken the battery out and put it back in.
  I select the blue ball that says internet and I get No Network connection. No signal found for mobile networks.

   Where on self serve would I find Blocked?
Userlevel 7
Badge +4
Ken Lang wrote:

Nope it's not working. My new $35 Plan includes data.
   Settings -- Data Usgae -- Mob...

Check under the "Add-ons"
Badge +4
Are you in 2G/GSM mode? To check, go to: Settings > More networks > Mobile networks > Network mode and select anything other than 'GSM only' (select WCDMA only or LTE/WCDMA/GSM).
it is set to LTE/WCDMA/GSM
I looked at Usage meter on Self service and it still says 0 MB of data used.  I don't see blocked data any where.
Badge +4
Ken Lang wrote:

I looked at Usage meter on Self service and it still says 0 MB of data used.  I don't see bl...

What's the model number of your S4? If it's the Canadian variant, it should be SGH-I337M. You can find the model number in Settings > About Phone/Device under Model number.
Ken Lang wrote:

I looked at Usage meter on Self service and it still says 0 MB of data used.  I don't see bl...

I got it working.  I took it back to the Koodo dealer and then called Koodo. They said the data was blocked.   I'm up and running now. Thank you.

Reply