Koodo Community

Community

Solved

Very Frustrating Self-Serve & Constant Data Issues.


No matter what Self-Serve link I use I eventually get a "Page Not Found" or a message telling me that I need the account holders permission and if I am the account holder (I am) to log out and back in. Very frustrating. I've tried using my phone (when it stays connected for more than 30 seconds), my laptop, PC, all with multiple browsers.. Nothing! I haven't seen a website with this many broken links since the 90's. Between that and my data continuously dropping (every third or fourth click I make) it seems like a provider change may be in order. If I had a dime for every "Page Cannot Be Displayed" I've had with Koodo, I'd make Bill Gates look like a hobo. Hate to say it, but I'm about to bid Koodo a frustrating "Adios, Amigos". (Get it?)

4 replies

Userlevel 7
Badge +4
Hello Dan I'm pretty curious to know, are you the account holder? Because since I'm with Koodo I've never had a broken link in my life. So my question is what are you doing wrong to get so many errors?
Userlevel 7
If the site tells you that you need the account holder's permission, then it usually means the account you are signing into is not the first account created for that phone's account. Did you recently create a new self serve account?
Userlevel 7
Badge +4
This link may help http://help.koodomobile.com/self-serve/logging-in/i've-just-registered-for-a-new-account-but-only-see-a-link-accounts-page-when-i-log-in-how-do-i-view-my-account
Userlevel 3
Hello Dan, 

Have you also tried the suggestions mentioned here http://koo.do/1NJqRrQ? Were you able to contact us?

Keep us posted!

Reply