Koodo Community

US boosters don't work - Nexus 5


I am using a Nexus 5 on a prepaid plan.
I bought US boosters for data, talk, and text - spending over $150. I tried using them in Phoenix last November and did not work. So when I came back to Canada, I checked all the Koodo forums and message boards to see what I could do.
When I was in Houston a few weeks ago, I tried all of these things: restarting my phone with and without my sim card, turning off the automatic selection of carriers and manually selecting all the providers one by one (AT&T, Verizon, Sprint, etc.) but none of that worked.
Luckily I was still able to communicate as the hotels I stayed at has wifi.
I'm going to the US again in two months and if this does not get resolved, then I will either ask for a refund and switch to another carrier.

15 replies

Userlevel 7
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?
Did you have a signal out there?  Were you able to connect to AT&T?No signal at all - no bars. Couldn't connect to any of the providers. Just an error symbol with the triangle in the status bar?
Userlevel 7
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?So when you changed to manual, you can see the US networks but you couldnt connect to them?
Did you have a signal out there?  Were you able to connect to AT&T?Correct - I could see a number of them in the list and I tried connecting to everyone of them, but nothing worked.
Userlevel 7
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?Have you tried to reset your network setting?

Settings> Networks & Internet https://lh3.googleusercontent.com/nHFGZ_9xjCh-mP83zMzXQVJF5VYf2n6kwoBIxB2zv3V4VPT4gNTtBye8lYznogLqLPY=w13-h18 More https://storage.googleapis.com/support-kms-prod/ArAlBcUAe8h1l5m69uxnwElxkqwW0QdtIc3F https://lh3.googleusercontent.com/nHFGZ_9xjCh-mP83zMzXQVJF5VYf2n6kwoBIxB2zv3V4VPT4gNTtBye8lYznogLqLPY=w13-h18 Reset Wi-Fi, mobile & Bluetooth.
Did you have a signal out there?  Were you able to connect to AT&T?Yup - I tried that too, resetting the settings, and then chose the carriers again one by one.
Userlevel 5
Did you have a signal out there?  Were you able to connect to AT&T?Barrie please make sure your network settings are on:

LTE/GSM/WCDMA (auto connect) and [i]not LTE only or GSM only.

Make sure you enable [b]ROAMING DATA  and you network selection is on Automatic.

If nothing works, try to put you SIM in another device just to double check that the issue is not with your device.
Userlevel 7
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?You might need to contact Koodo (private message via facebook or twitter) to see if there is something up with your account
Did you have a signal out there?  Were you able to connect to AT&T?Thanks both.
TJ - I tried that too and even used a different phone the second time, but it was also a Nexus 5.
Dennis - I will contact Koodo and see.
Userlevel 7
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?It may be your SIM if you have the same problem with another handset, unless the Nexus 5 is a special case. Best to contact tech support.

I winter in Arizona and have had bullet-proof service on both a Samsung Note 2 and an LG G3 around Yuma, Phoenix and the Mexican border. When I boot the phone, it lights up and gives a momentary searching message (like when you boot back home) and then shows AT&T as carrier on the home screen. No warning triangles. Use TJ's settings above. One last step would be to toggle the LTE on and off.

Yes, it's a hassle. But it may be cheaper to buy another SIM and/or use a cheap US refurb Android phone than to eat the $150 in boosters if a refund is refused.
Did you have a signal out there?  Were you able to connect to AT&T?Thanks Bob - will contact tech support and try what you mentioned.
Badge +4
Did you have a signal out there?  Were you able to connect to AT&T?Ok Barrie, this might seem like a dumb question, but this phone works in Canada and you have an active base plan? If yes to both then the problem is on Koodo end or your Sim is acting up. You have done everything to fix the problem unless Koodo and Nexus 5 just don't get along.
Did you have a signal out there?  Were you able to connect to AT&T?Yes Mats - the phone works in Canada and I use it for one of Koodo's prepaid plans.

Reply