Koodo Community

Community

Solved

Unregistered sim


My phone suddenly showed that it had an unregistered sim. Should I be worried about this? After a restart it appears to be fine but I'm still wondering if it should be a concern.

11 replies

Userlevel 7
Badge +4
It might be starting to fail, or maybe it didn't make the connection properly Kristen. Just keep an eye on it and if it starts to happen regularly, you may need to consider buying a new SIM card.
Userlevel 7
Badge +4
You can also remove and re-insert the SIM should it happen again. Depending on the travel time to a Koodo outlet, you may wish to purchase a spare SIM sooner, rather than later. They don't go bad!
Userlevel 7
Badge +4
David wrote:

You can also remove and re-insert the SIM should it happen again. Depending on the travel time...

I wouldn't recommend buying SIM ahead of time. I've had plenty that were DOA. Buying one just in case and then finding out that the replacement doesn't work isn't a situation I'd care to be in, considering that most carriers' cards are easily found locally.
Userlevel 4
Kristen what kind of phone brand and model do you have?
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

Samsung a5 is my current phone.
Userlevel 4
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

There is a well known problem with Galaxy s4 that has nothing to do with SIM but need costly repair of the phone itself. That is why I asked for the Model and Brand of your phone.

Unfortunately I don't know if it is the same case with a5 as well.
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

I am having this same issue with my A5. Did you find anything else out? Did you try taking SIM out and re-inserting...if so did it work?
Userlevel 7
Badge +4
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

Kathleen, please try it - if that doesn't solve it, you may need a new SIM card. If you still have questions it would probably be best to start a new topic, so we can troubleshoot you better 🙂
Userlevel 4
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

Hi Kathleen,
Prior to that did you drop your phone? Is your phone exposed to constant shaking or rough conditions.
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

It did have a bit of a bump last weekend. This would be 8 or 9 days later that I saw the message.

I will try taking the SIM out and see if that helps. I would be surprised that it would need replacing because the phone is quite new...only about 2-3 months.

Thanks for your imput! 🙂
Jan Hope wrote:

Kristen what kind of phone brand and model do you have?

So I just tried powering off and on. That seems to have worked. Thanks.

Reply