Koodo Community

Community

Solved

unlocked rogers note 2 connected to koodo hspa, but cannot make calls or send texts. When connected to utms or lte, those can be made.


As the title suggests, I have an unlocked Rogers note 2, I317M running stock firmware. I am connected to koodos prepaid hspa network (checked under settings, about device, status) but I cannot make calls or receive texts. In the occasional moments that I'm connected to utms or lte, everything works fine. Yes, I've pulled out battery and sim. I'm also done full factory reset including flashing 4.3 stock Rogers rom and wiping system partition/cache. Is this a sim issue or should I get my phone checked out on its hspa radio antenna? I just checked on my koodo nexus four and its having the same issue, so its unlikely to be the note 2. Does the prepaid only allow for lte which might be rare in my area (Richmond bc)

5 replies

Userlevel 7
Badge +4
Koodo only uses 4G LTE and 3.5G HSPA+ aka wcdma aka UMTS (this an improved version of the 3G HSPA).
That is weird, looking at the setting screen (setting, more, about device, status, mobile network type), I've connected to three different mobile network situations. Two situations when my phone is working - lte and umts, and hspa when it doesn't work. Going into dialer #*2263# and choosing wcdma only leads me to connect to hspa which doesn't work. I have no idea why there are both hspa and umts showing up. The way of resolving the issue is selecting automatic connection and once in a while when the settings screen shows lte or umts I can make calls and text. Most of the time it shows hspa which doesn't work. When I'm connected to lte, it'll stay connected to lte and work until I restart device. Then, it'll revert back to hspa and I'll have to wait until I get an lte connection. Waiting time varies greatly.

Back to the question, do you think it's a sim issue or phone problem? Does koodo only give lte and not hspa to certain phones thus my phone not working when there is not lte.
Userlevel 7
Badge +4
Alexander Ding wrote:

That is weird, looking at the setting screen (setting, more, about device, status, mobile ne...

So does connecting to UMTS work?
Alexander Ding wrote:

That is weird, looking at the setting screen (setting, more, about device, status, mobile ne...

It does, but I choose automatic connection so it rarely ever gets UMTS. It will connect to UMTS for maybe 5 seconds (I have time to send one text), before switching to HSPA. At least for lte it says there until I reboot. If I choose hpsa preferred or wcdma preferred the settings show hspa not umts. Choosing lte only gets me no network found. Thank you so much for your time.
Alexander Ding wrote:

That is weird, looking at the setting screen (setting, more, about device, status, mobile ne...

In addition, if settings menu say hspa I get no data indicator (isn't surprising since no calls or texts work either). Umts shows 4G while lte has the lte indicator. I guess the real question is how to get a connection to lte and UMTS instead of hspa.

Reply