Koodo Community
Solved

Unlocked LG V20 (H910) can send/receive calls but no data


I recently bought an unlocked AT&T LGV20 model H910. I swapped my Koodo sim card from my old phone into this one, and it's showing my carrier as koodo, I've got 2-3 bars reception, can send and receive calls, however I cannot access the internet with my data. Data is turned on, I even added an APN as I've seen suggested. I've tried everything suggested I can find and I'm pulling hairs out trying to get this to work as I love this phone otherwise so far and don't want to go through the process of returning it.

Some suggestions say to select network type but that option isn't in my settings. Any ideas? From everything I can find my phone should be compatible with koodo's network so I'm not sure what's up...
icon

Best answer by BobTheElectrician 26 June 2019, 16:38

The solution may be as simple as updating your APN file. Here's the suggested template:

https://www.koodomobile.com/help/setting-data-your-non-koodo-phone

Settings => Network => Mobile networks =>
  1. Make sure Mobile data is on
  2. Network mode is GSM/WCDMA/LTE auto
  3. Check your APN. On my V20, the APN protocol item reads IPv4 instead of being blank.
View original

13 replies

Userlevel 7
Badge +4
The solution may be as simple as updating your APN file. Here's the suggested template:

https://www.koodomobile.com/help/setting-data-your-non-koodo-phone

Settings => Network => Mobile networks =>
  1. Make sure Mobile data is on
  2. Network mode is GSM/WCDMA/LTE auto
  3. Check your APN. On my V20, the APN protocol item reads IPv4 instead of being blank.
Hey Bob, I already set up an APN using that webpage, and still no sauce. My Mobile data is on. As for Network mode, this setting isn't available in my network settings. Under Network I have;
  • Mobile Data (on)
  • Mobile Data reminder
  • Review reminder settings
  • International data roaming (off)
  • Disable 2G (off)
  • Access point names
  • Network operators
  • Search for AT&T MicroCell
Nothing about network modes. As for APN... you're right, my APN protocol reads IPv4 as well but I have no option to make it blank. I can choose IPv4, IPv6 or IPv4/IPv6
Userlevel 7
Badge +4
I think the issue was at the APN, I would double check if everything is correct again (vs Bob Link). If possible, can you take a snapshot of the APN settings and post here (delete/hide all personal before posting pls).

Also I would try to reset the network settings and restart the phone.



I'll try to reset and restart the phone. Tried earlier with no luck but I'll try again.
Userlevel 7
Badge +4
The APN settings look correct. Can your V20 have multiple APN profiles? I am wondering if you would have to select the desired APN and set it active. I was thinking about the possibility that your phone might be set to another APN.
Tried resetting network and restarting, still no sauce.

The APN settings look correct. Can your V20 have multiple APN profiles? I am wondering if you would have to select the desired APN and set it active. I was thinking about the possibility that your phone might be set to another APN.

I'll try this. Should I just make another Koodo profile the same as the first? Right now it looks like this;


The yellow dot indicates it being selected I assume, as when I first made it it was grey and I had to click it. But I'll try making a duplicate and swapping between them.
Tried the above. Still no luck. Is there any chance it might be because my signal isn't strong enough? Like I said, I can make calls no problem so it's not like I'm not connecting to my network, it's just enabling my data that seems to be a problem. I have doubts it's due to signal strength though, my old phone could access data on one bar, and I can get 3-4 bars if I go outside and still not access my data.
Userlevel 7
Badge +4
If you have data in your plan, you should be able to access it (LTE or 3G) when you could make/receive call and got signals.

I would suggest you check self serve again and make sure there isn't any data block in the account. After that, reset the network settings.

If all don't work, you might want to reset the phone to its default factory settings, and see if that can help. If not, you might have a real issue with hardware. Also, if possible, try the phone with another SIM from another carrier.
I figured.

I just checked and there's no data block that I can see and I should have about 80mb left for this month. I'll try another reset, and if that fails, I'll try another factory reset (did that yesterday to no avail but I'll try again.)

I was worried it might be hardware related, as this is a refurbished phone. Worst case scenario I have to return and get a refund, as much as I don't want to go through that.

I'll reply with results after I fiddle around some more.
Userlevel 7
Badge +4
Just for giggles, turn ON International data roaming. A phone with AT&T firmware might well be interpreting a Canadian provider as foreign. You can also Disable 2G.

The Bands supported by model 910 should not be an issue with Koodo, Telus or Bell as the home frequencies are the same. I regularly roam with AT&T and T-Mobile in the US with a Cdn spec model 915.

https://www.gsmarena.com/lg_v20-8238.php#h910
Tried both a network reset again, as well as factory, still nothing. I'm really confused by this. If it WAS hardware related, wouldn't I just have no signal at all? It makes no sense to me that I can still call 611 and get my self serve, i can call my folks, I can send texts and it says I'm connected to the koodo network yet I can't use my mobile data.

Just for giggles, turn ON International data roaming. A phone with AT&T firmware might well be interpreting a Canadian provider as foreign. You can also Disable 2G.

The Bands supported by model 910 should not be an issue with Koodo, Telus or Bell as the home frequencies are the same. I regularly roam with AT&T and T-Mobile in the US with a Cdn spec model 915.

https://www.gsmarena.com/lg_v20-8238.php#h910


Tried this as well, still nothing. I'm going to take the phone in to town with me when I do shopping friday and see if I can get a tech to look at it and figure anything out, because I can connect to the network, call etc.. I just need to get that damn mobile data working as I text via apps like discord and telegram, which require mobile data. If I can't do that it kinda negates half the reason I even have a phone.

Userlevel 7
Badge +4
I would try to test the Koodo SIM in another phone and see if you can access data. Also, if you have another SIM from another provider, I would test it in the phone also.
The sim card works in my old phone fine (A moto G gen 1). Thanks for the help guys but the phone just took a jump off the deep end, definitely more problems than just the data and I'll be requesting a refund for it.

It's a refurbished phone, but it just started acting terribly, randomly freezes and crashes now, as well as getting stuck in a reboot loop (It will crash, attempt to reboot, crash, etc.) The screen also began flickering badly. 😞 At least it decided to crap out while I am still covered by the sellers return policy.

Reply