Koodo Community
Question

unable to connect to a network

  • 28 January 2016
  • 2 replies
  • 15 views

Hey everyone, I'm having a problem with my LG G3 (model number D852) - all of a sudden it can't connect to a network. I've tried manually searching for networks with GSM, WCDMA, and LTE all enabled; it comes up with results from Koodo (LTE and WCDMA), as well as some from Videotron, Bell, and EXT (Rogers/Fido). Neither of the Koodo ones are working for me, and I don't know what to do. 

Despite the sim card being smaller than the one originally in my old phone, if I place it right I have a network connection on there. Likewise, I can connect to Wi-Fi on my G3, and everything but the network appears to be functioning normally.

I've tried removing the battery and the sim card in every possible combination and as previously mentioned, the sim card works in another phone.

Please help, I don't want to have to try a factory reset because I have a lot of stuff on here that I want to hold on to.

2 replies

Userlevel 7
Badge +4
Try the Rogers Ext one. If it works you're in an extended coverage area. Your phone will show you're roaming. That's okay

Where did you get your G3? On another note, since you still have access to the rest of the phone you.can still backup all of your photos and documents before you try a factory reset.
Userlevel 3
Hi Daniel! Were you able to connect to our network? If not, please give us a call at 1-866-995-6636 opt 6 and Technical Support will be glad to help you out . Try to call us from another phone if you can 🙂 Have a great weekend! 

Reply