Koodo Community

Community

Solved

Turn on data Galaxy S2


I have been using my phone without a data plan, and have now moved up to the $37.00 plan that includes 150mb of data. I have tried everything I could find on turning data on. Settings, More Settings, Mobile networks, green checks by Mobile Data and Data roaming, but when I am away from my wifi the phone said No signal found for mobile networks and this is at a number of locations. What am I missing?

2 replies

Userlevel 7
Do you have your data blocked by Koodo?
Userlevel 6
Badge +4
Check your account on Self Serve, under Add-ons, check if you have the DATA BLOCK, if it is there, remove it from account. You can also check the APN settings on your cellphone to see if those are the correct ones, check the link: http://help.koodomobile.com/plans-add-ons-data-and-other-services/data-basics/how-do-i-setup-data-on-my-non-koodo-phone If still not working, try to get in contact with Tech Support from a different phone for some troubleshooting...

Reply