Koodo Community

Community

Solved

tried dialing, get message "not registered on network" help


7 replies

Userlevel 7
Badge +4
Hello MacQuarrie.

Do you have any service? Can you at least text?
Robert wrote:

Hello MacQuarrie.

Do you have any service? Can you at least text?

can't text - think it is the sim card
Badge +4
Try Settings > More > Cellular networks > Network operators - the path to get to this setting may differ slightly on your device. Manually scan for available networks, when Koodo appears, tap to select it and a message should appear, 'Registered on network'. If that doesn't work, there may be a problem with your SIM card.
rikkster wrote:

Try Settings > More > Cellular networks > Network operators - the path to get to this setting ma...

believe it is the sim card
Badge +4
rikkster wrote:

Try Settings > More > Cellular networks > Network operators - the path to get to this setting ma...

Let us know if the new SIM card fixes the issue.
Userlevel 5
Hey there,

Have you tried to insert your SIM in another phone to see if it works? If it works, you can insert it again and make sure it's clean and that it's aligned on the SIM Tray. However, if it doesn't work, Rikkster's probably right, it might be necessary to change it, if you've had the same SIM card for a long time.

Let us know if you still need help! 
Tayeb A wrote:

Hey there,

Have you tried to insert your SIM in another phone to see if it works? If it works, y...

thanks, believe it is the sim card - have had it for a long time.

Reply