Koodo Community

Community

Tethering Samsung Galaxy S4


I enabled tethering/wireless hotspot on my Samsung Galaxy S4. My laptop has no problem connecting to the hotspot but it shows there is no internet access. What;s wrong?

20 replies

Userlevel 2
No idea. Nothing Koodo can do about it either as tethering is a service they don't support for troubleshooting.
Userlevel 7
Myke wrote:

No idea. Nothing Koodo can do about it either as tethering is a service they don't support for tr...

The community normally can help even when Koodo doesn't support certain functions. Since we're made up of customers and employees,I'm sure Someone here may have an answer or be able to help.
Userlevel 7
Badge +4
I've had this problem some times too. Try restarting your hotspot couple times. I didn't find what the solution for this was! Maybe try other way of connecting?
did you manage to get connected? tried the USB tethering and got the same result.
Userlevel 2
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

This might be a silly question, but is the S4 a Koodo phone? Or from another carrier?
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

directly from the manufacturer.
Userlevel 7
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

If you can change the security type or password try that. Also be sure your laptop wifi is set to grab an IP automatically and not trying to assign a static IP
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

i tried WPA2-PSK, OPEN, and WPA PSK, nothing worked. DHCP on my laptop.
Userlevel 2
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

As far as I'm aware, no Koodo phone prevents tethering because it is not prohibited. However, seeing as you bought your phone from a source other than Koodo, it is possible that the firmware in your phone does not allow tethering. How do I know this? I used an Android phone that was originally from TMobile that was unlocked. I tried to tether but it wouldn't work even though my tablet was able to connect to the hotspot. Found out that the firmware in the phone was checking if the account had tethering enabled, probably through some system's check. Obviously, my account is not with TMobile so any check would come out negative. Anyway, to make it short, it wouldn't work because of the firmware. I suspect you may be in the same boat.
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

can I get the firmware changed to get it work? Thanks.
Userlevel 2
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

The manufacturer controls the firmware, not the provider.
Userlevel 7
Kevin Lu wrote:

did you manage to get connected? tried the USB tethering and got the same result.

Well since this is your phone you could root it and (after backing up the original firmware) install a custom rom. That might solve your issue. Btw tethering a laptop uses a ton of data. Be careful. $$$$$
Userlevel 7
Have you been able to wifi tether other devices? Phones?
tried Wind and it didn't
Koodo gives you 3 APN's.. Clearnet , Koodo, and Telus. Delete the Clearnet and Telus ones and just keep the Koodo APN. I did this and the tethering function started working flawlessly. Phone = Galaxy S4 mini i9195
Userlevel 2
Koodo does not give you 3 Apn's. They only use 1.
Userlevel 7
Myke wrote:

Koodo does not give you 3 Apn's. They only use 1.

Unlocked phones from other networks may show more than just the koodo APN
Go to your APN settings. On a Samsung Galaxy S5, for example, this is in Network Connections >> More Networks >> Mobile networks >> Access Point Names >> (your active APN) >> APN type. You'll probably see something like "default,supl,mms". Add "dun" to the list so you'll have something like "default,supl,mms,dun". You should now be able to access the Internet on any devices tethering off yours.
colan wrote:

Go to your APN settings. On a Samsung Galaxy S5, for example, this is in Network Connections >> ...

You nailed it! This worked perfectly for me. Many thanks Colan. (What an obscure setting!!)
Userlevel 7
Badge +4
Echo Chad Burr above. 10 minutes of tethering just to check email and minor surfing ran up 30 megs of data while my landline was down. Many sites will force-feed full res images, etc unless the requested device (your laptop) proves it's a mobile.

Reply