Koodo Community

Community

Tethering fix on Koodo with HTC Desire 320


I recently switch from Telus to Koodo and could not get tethering to work on my phone. It worked fine with Telus. After searching the internet and this forum I discovered it was a common problem. Koodo teck support refused to give any help with hotspot issues. My hotspot would turn on and my ipad and tablet would recognize the network created by my phone but I could not connect to the internet.
After spending too many hours working on this problem, I discovered the article listed below.

https://pmf.silvrback.com/fixing-tethering-on-android-kitkat

This explained the issue and the fix. Then using the video below I was able to download and install the tools needed to modify the developer settings in my phone.
  https://www.youtube.com/watch?v=MVXX-YdhRU0
You only need the two two items (platform tools and not all the other version stuff for this fix.

After I got into the adb shell I was able to run the command which essentially set the dun (dial up networking) setting to zero.

This is what the lines looked like in the CMD Window

C:\Users\Owner\Downloads\android-sdk_r24.4.1-windows\android-sdk-windows\platform-tools>adb shell
shell@htc_v01_u:/ $ settings put global tether_dun_required 0

The first line shows the path to the folder with the platform tools on my computer and opening the adb shell
The second line shows where I type in the command from the first article.
After I did that I was able to get internet on both my ipad and tablet through my phone's hotspot.
I
I hope this rather long first post helps some other users out there.

2 replies

Well I'm glad someone else is Tech Savvy enough to explain such thing as being Root and ADB haha. You did a very good work sir, unfortunately the most common users of the Koodo service won't know what you're talking about, but I do appreciate this. 🙂 Have a nice one. 
Userlevel 7
Badge +4
Thank you very much for sharing! This will be helpful for people in the furturr with a similar problem. Glad to hear you got your servuce back up and running as well.

Reply